Chromecast on Uniti Atom - Gapless playback

As Qobuz has to be played on the Atom via Chromecast built-in, I was wondering if anyone knows if gapless playback is simply impossible with Chromecast technology or if it's the Apps doing the casting are to blame?

I got a Chromecast audio device a few months go and hooked it up via optical to an older amp, and was dissapointed to find it could not do gapless playback.

Just purchased an Atom but the Chromecast built-in has the same problem which is a shame for those of use with Sublime/Sublime+ accounts.  I suspect it's down to Chromecast technology, but it could also be a hardware limitation of the Qobuz iOS app.

It's also a real shame there's no native support for Qobuz as there seems to be for Spotify/Tidal (which I don't use), it would be great if this was in the pipeline as that might circumvent this issue.

Playback from a WD MyCloud NAS is gapless, but that naturally relies on purchasing the content not having a streaming plan.

Thanks in advance.

Original Post

Cheers.

I did a search, perhaps with the wrong phrase however, or certainly not in the replies I browsed.

Assuming Cast Screen mode is Android only?

Just noticed I meant 'software limitation of the Qobuz iOS app.' not 'hardware'.

I did query with Qobuz support a while back and they suggested it was not feasible, but perhaps they just don't want to implement gapless....

 

 

On Windows, from Google Chrome, you can also use Cast Desktop, I believe that also works gapless, but I'm not entirely sure.

There's also the from Google Chrome Cast Tab option but that needs the audio stream to be sent via a browser tab.

Update: With the last update to Chrome, Cast Desktop no longer works at all on Mac, and generally no longer works on most PCs either.  If if you're 'lucky' enough that it might work on your PC you'll quite probably have to disable your anti-spyware package and parts of your anti-virus system!

Way to go Google!

Many thanks for doing some digging around in relation to this.

It really seems odd that Google don't have a Mac driver to allow audio output from any App to their device on MacOS anw want people to use Chrome.

I currently have a Qobuz Sublime subscription (streams at CD quality, or your purchases in HD in iOS), and would upgrade to their Sublime+ package if I could get gapless streaming from iOS or macOS.   If I can only easily get gapless via a NAS and have to purchase the items to do so, it's a shame.

When you look up "issuetracker.google.com/issues/36191370" in the internet you will find out that Googles Chromecast protocol will probably never support a proper and easy implementation of gapless playback which is a problem of Chromcast and a shame in my eyes. I don't know whether the new Naim series supports the open home standard. If so you could use BubbleUpNP (Android only) as controll app that will recognize an open home renderer and stream Qobuz gaplessly to your Atom. Works nicely with my Naim Muso that seems to follow the open home standard. At least it is recognized by BubbleUpnP.

It's entirely possible to transmit gapless using Chromecast.  The trick is very simple - don't drop and re-initialise the Chromecast connection for each track.

The way to achieve this is equally simple, cast the screen instead of using cast from within an individual app.  This does work.

Wolf R posted:

Of course this is a possibility, meaning you have to let your controller device switched on all the time. To me this is not how streaming should work properly.

Then just use DLNA rather than Chromecast.

(Strangely enough you still have to leave the DLNA server switched on all the time when playing...
Thinking about it, that's just the same as with Chromecast actually - you have leave the device transmitting the Chromecast connection switched on all the time while playing!)

Huge posted:

It's entirely possible to transmit gapless using Chromecast.  The trick is very simple - don't drop and re-initialise the Chromecast connection for each track.

The way to achieve this is equally simple, cast the screen instead of using cast from within an individual app.  This does work.

Huge, could you just explain how this is done. I use CCA to stream Qobuz and to cast from my PC via Plex Media Server. Ethernet connection into the Naim DAC. Use IPad/IPhone to select/play music. More than happy with SQ, but frustrated with not having gapless playback. Thanks.

HardBop posted:
Huge posted:

It's entirely possible to transmit gapless using Chromecast.  The trick is very simple - don't drop and re-initialise the Chromecast connection for each track.

The way to achieve this is equally simple, cast the screen instead of using cast from within an individual app.  This does work.

Huge, could you just explain how this is done. I use CCA to stream Qobuz and to cast from my PC via Plex Media Server. Ethernet connection into the Naim DAC. Use IPad/IPhone to select/play music. More than happy with SQ, but frustrated with not having gapless playback. Thanks.

I'm sorry, this doesn't quite make sense.

"I use CCA to stream Qobuz"
CCA doesn't support Qobuz, all it does is provide a local WiFi connection from a device to a 3.5mm jack (analogue and or S/Pdif).

"cast from my PC via Plex Media Server"
The Plex Media Server doesn't support Chromecast, only the Plex mobile apps and the Plex Browser app for Google Chrome

"Ethernet connection into the Naim DAC"
The Naim DAC doesn't have an Ethernet connection.

I'm not sure how you're connecting things up, as I can't work out what you're actually doing here.

 

"cast from my PC via Plex Media Server"
If you are casting from the Plex client app in a Chrome browser window on the PC, this should be gapless.  If it isn't, then when casting from the PC, instead of choosing the <Cast Tab> option use the <Cast Desktop> option (N.B. this needs a fairly recent CPU).


"Use IPad/IPhone to select/play music"
This suggests that you're using the iOS client to connect to the Plex Server, and render the music on the iOS device, if this is the case, the problem lies with the Plex App not the Chromecast.  It seems that the Plex app's Chromecast implementation is putting the gaps in (as many apps do).


Using an Android device make it much easier.

Sorry need to explain my set up a bit clearer. I've a "typical" Naim set up, multi-box and using the NDac into XPS2; but no streamer. PC in another room with my router. Ethernet connection from the router into the CCA which sits with my hi-fi. Optical connection from CCA to the NDac.

I have a subscription with Qobuz and use an IPad/IPhone to stream content to the hi-fi. I In my simplistic view CCA is the device which is enabling this action. I don't use the PC at all for listening to music.

However, I still download some hi-res files (from Qobuz and other sites) and these are then stored on my PC. Plex Media Server then "casts" these and ripped CDs via CCA(?). Again I use the IPad/IPhone to select/play music to the hi-fi.

I have read there is a separate app "Hi fi cast" I think, which enables gapless playback but this is android only. I've also seen many posts on a number of web-sites bemoaning the lack of gapless with CCA, so I thought I was resigned to not being able to play gapless. It is of course usually only an issue with live or classical music where gaps are particularly noticeable and hence annoying.

Thanks     

First to determine in what mode the Plex app is using the Chromecast we need to do a test (I don't have Plex, so I can't test it for you).

Stream a track from Qobuz and, just after it starts, stop the Plex app on the phone (don't just turn the phone's screen off as that doesn't test anything to do with the app or its communications.  Instead bring up the carousel of active apps and swipe the app off the screen (or actively close the app).  Does the music stop?

Next do the same but with a track playing from the Plex Media server.

While doing this if the track continues to play, it's worth doing the follow-up test and set-up a playlist of two or more tracks - than see if it will continue across more than one track.


The only way I can be certain to get gapless playback from Chromecast is by using an android device.  It doesn't have to be anything at all sophisticated, a £80 tablet from Argos will do fine!

Unfortunately, gapped playback remained. I tried fully closing the Qobuz app. with a stream and closing the Plex app. with a downloaded file with the same result. The only way I can get gapless playback is to copy any downloaded music onto USB and then play it through the DAC; as I always did before getting CCA.

Never mind, thankfully the need for gapless is limited to only a few files/streams, so something to live with, unless I choose an android device to cast via CCA.

Thanks.

There are two ways to use the Chromecast API.

1   In the first method (the easy / lazy solution), you first select the device to which you want to cast, then get a URI for the resource you want to cast to the device (e.g. the network location of the file) and pass this to the Chromcast API.  The Chromcast library opens a connection to the selected device, plays the content of the resource and closes the connection when finished.  The repeated opening and closing of the Chromecast connection and repeated creation and deletion of a stream entity for each new resource (i.e. track to be played) is what causes the gaps in playback.

2   In the other method you select a device, create an empty stream, open the device connection using the stream (by passing this to the Chromcast API).  Then you open the resource you want to play and render its contents to the stream (and hence through the open connection to the device).  When the stream finishes you have to manually close the resource you were rendering to the stream.  At this point you can either open / play / close another resource, or close the connection to the device and delete the stream you created. This requires the app itself to control both the stream and the Chromecast connection rather than using the Chromecast library to do it.  This is a lot more work, but can be gapless.


Don't blame the Chromecast or it's library, the cause lies squarely with the writers of the Apps who are choosing the quick and easy route, even though that approach doesn't do gapless replay.  If they put in the effort to use the other method the apps would do gapless perfectly well.

Good explanation Huge.

I can quite see that Gapless should be entirely feasible in software as the Chromecast Audio device has no idea what the stream is and just plays it, so it should be entirely feasible to append the bitstream for one track to another to achieve this.

Alley Cat posted:

I currently have a Qobuz Sublime subscription (streams at CD quality, or your purchases in HD in iOS), and would upgrade to their Sublime+ package if I could get gapless streaming from iOS or macOS.   If I can only easily get gapless via a NAS and have to purchase the items to do so, it's a shame.

My current Qobuz solution is to use MacOS Audirvana+ v3 which sends a UPnP stream directly to Mu-so in HiRes, even waking it up if in standby. This is gapless, and Audirvana also controls the Mu-so volume. If you look at the Mu-so with the Naim app while a track is playing you can see the the artwork, track name etc. I don't (yet) have a new Uniti but it seems likely that the artwork will appear on its screen. You can also control everything from an IOS device using Audirvana A+ Remote.

david

 

DavidS posted:
Alley Cat posted:

I currently have a Qobuz Sublime subscription (streams at CD quality, or your purchases in HD in iOS), and would upgrade to their Sublime+ package if I could get gapless streaming from iOS or macOS.   If I can only easily get gapless via a NAS and have to purchase the items to do so, it's a shame.

My current Qobuz solution is to use MacOS Audirvana+ v3 which sends a UPnP stream directly to Mu-so in HiRes, even waking it up if in standby. This is gapless, and Audirvana also controls the Mu-so volume. If you look at the Mu-so with the Naim app while a track is playing you can see the the artwork, track name etc. I don't (yet) have a new Uniti but it seems likely that the artwork will appear on its screen. You can also control everything from an IOS device using Audirvana A+ Remote.

david

 

Thanks for posting that David.

I had Audirvana2 + and I came across another post about the UPnP feature so tried the 3+ demo and it worked but unreliably - maybe 50% of the time it would quit playback or not see the Nova as an output device - a real chore to have to go back to select it in output Preferences.  I upgraded anyway to support the development but currently I'm having little success with the Nova appearing as an output - I have installed Roon software and hope it's not this conflicting, but the issue was there before.  Connection via Naim apps and using chromecast built in to play Qobuz has been rock solid apart from the gapless issue and lack of cover art (naturally I assume). 

Out of interest I assume you have Sublime+ - do you find titles unavailable to stream in HD are common if available to buy?  Is it the titles that don't seem to offer a Sublime purchase discount?

DavidS posted:
My current Qobuz solution is to use MacOS Audirvana+ v3 which sends a UPnP stream directly to Mu-so in HiRes, even waking it up if in standby. This is gapless, and Audirvana also controls the Mu-so volume. 

david

Artwork does show, but sadly but having tested this again I cannot get it to do gapless with the Uniti Nova.  I am also seeing stability issues whereby tracks fail to play one after another and occasional crashes requiring a Force Quit.  This is with Audirvana 3 running on a 2015 MacBook Pro streaming via wi-fi to an ethernet connected Uniti Nova.

Hi @Alley Cat That is disappointing and rather puzzling.

Similar to you, I run Audirvana Plus v3.1.7 on an iMac connected via Wi-Fi, with the Mu-so on Ethernet. I just tried (Mon 30/Oct 8pm GMT) playing Pink Floyd The Dark Side of the Moon from Qobuz (the one with the red label top left) to Mu-so UPnP and there was definitely no gap between track 2 Breathe (In The Air) and track 3 On The Run, just a long note (the last note on track 2 at 2:49), continuing until about 10s into track 3. Same between tracks 3 and 4 with an unbroken electronic rumble before the alarm clock about 10s into track 4.

On Sunday afternoon, Qobuz went through a bad patch with tracks and favourites failing to load. Normally the first track loads quickly as shown by the grey bar moving across. When Audirvana switches to the next track, it should already be loaded (grey bar).

Might be worth another try?

Could I ask if you are playing back a local gapless album from a NAS or other local storage or if streaming from Qobuz.

I'll try the Division Bell locally tonight rather than via streaming.  Marillion's Misplaced Childhood did not play gapless earlier when streamed from the internet - I can imagine an overhead between tracks for internet playback, will try local files.

Thanks David

Roon seems to do audio playback flawlessly, but it does not allow for Qobuz integration to stream things I haven't purchased and downloaded.

Audirvana naturally allows me to stream items I've downloaded from Qobuz to a folder or direct via the internet if browsing things I've not purchased - I wondered if the internet streaming was introducing an overhead for each track if they weren't pre-fetched compared to stuff in a local folder.  Sounds as though you are getting gapless streaming from the internet not local files.

 

Was this solution already mentioned here? Try to install "Bubble UPnP Server" on your NAS. Set it up as a proxy for your streamer in the Bubble UPnP Server settings. Remember to check the "gapless playback" checkbox. And then use the Bubble UPnP app (Android) or Lumin or Kazoo app (iOS) to stream to the proxy (that is called "... (Openhome)" where "..." is the name of your streamer).

This solution works quite good. Though on my NAS (Synology DS213+) it works not perfectly. I think the NAS is a little bit too slow and/or has not enough RAM. I want to get a better one soon, not only for streaming qobuz.

@Alley Cat Yes, I am streaming Qobuz albums I haven't purchased directly from the internet. This morning I repeated the test for gapless using the same Qobuz album "The Dark Side Of The Moon" with the red label top left:

1. IOS Qobuz App > Chromecast Audio > Mu-so digital input
GAPS BETWEEN TRACKS
The Chromecast is connected via Ethernet (not Wi-Fi) to the local network and internet, and is sending a digital stream via a TOSLink cable to the Mu-so. My understanding is that when you play an album via Chromecast, the Qobuz app sends it a list of tracks. The Chromecast then fetches these tracks from the internet. The IOS app is no longer involved and even if you shut down your iPhone, the album plays to the end.

The downside is that there are short gaps between tracks (0.5 to 1s) while the Chromecast fetches the next track. This is quick on my set up but still very obvious on an album like this which was designed as a continuous stream of music. For conventional albums with gaps between tracks, the extra gap isn't usually noticeable

2. MacOS Audirvana Plus v3 > Qobuz > Mu-so UPnP input
DEFINITELY NO GAPS BETWEEN TRACKS
The iMac is connected via Wi-Fi. Audirvana is pulling the FLAC stream from Qobuz on the internet, buffering it internally, doing some internal magic and then sending it as a UPnP stream to the Mu-so (which is connected to the network via Ethernet). If you shut down Audirvana, the music stops immediately.

I have a Qobuz Sublime subscription and both solutions can stream the HiRes albums I have purchased from the internet. With the Audirvana solution you can check that this is the case from the Naim app Now Playing screen which shows the sample rate.

Audirvana is good solution for Mu-so. I can't say whether it would work with Uniti Nova.

david

 

gert posted:

Was this solution already mentioned here? Try to install "Bubble UPnP Server" on your NAS. Set it up as a proxy for your streamer in the Bubble UPnP Server settings. Remember to check the "gapless playback" checkbox. And then use the Bubble UPnP app (Android) or Lumin or Kazoo app (iOS) to stream to the proxy (that is called "... (Openhome)" where "..." is the name of your streamer).

This solution works quite good. Though on my NAS (Synology DS213+) it works not perfectly. I think the NAS is a little bit too slow and/or has not enough RAM. I want to get a better one soon, not only for streaming qobuz.

I hadn't realised until recently that BubbleUPnP Server can be installed on macOS. I tried this today, transforming the Mu-so into an OpenHome Renderer with gapless playback, and allowing it to be recognised by (for example) Linn Kazoo which supports Qobuz and Tidal. Within a few minutes I was streaming the same Qobuz "The Dark Side Of The Moon" album mentioned above to the Mu-so and confirmed that playback was gapless. As @gert says, this is another possible solution.

BubbleUPnP Server also does interesting things with Chromecast Audio but the documentation stresses that the created renderers "do not support gapless playback".

Thanks again David your iOS tests replicate mine and are expected by all accounts.

I can't fathom why Audirvana won't do gapless to the Uniti Nova if it does to Muso.  I may contact the developer as app seems buggy and often can't find the Nova or drops connection whereas Roon and various iOS device connections are fine - could be network I know but troubleshooting this kind of thing is a nightmare and it may just be something that can be tweaked in Audirvana - incidentally I'm runnning El Capitan not Sierra/High Sierra.

When I have time I may try to use Bubble.

Hi @Alley Cat

I'm interested because I've been thinking of getting a Uniti Nova 

There is one thing you could try. In Audirvana, while connected to Nova, you can capture details of the connection from the Audirvana Plus menu, choosing item Debug Info... This pops up a window with info you can Copy with a button at the bottom. Paste this into a text editor and search for the string Gapless. In the Mu-so info I found this section:

DLNA 1.5: Yes
Gapless playback: Yes
Can play native DSD: No
Number of channels: 2

It will be interesting to know what the Nova reports.

david

Hi David

I've been looking at that tab earlier.

No idea if it's the recent Roon compatible firmware update or not, but the Nova is not being recognised by Auidrvana+ unless I unplug/replug ethernet on the Nova, whereas Roon and iOS Naim apps find it without fail.

Even rebooting the Mac in case it was Roon hogging access did not help.

I then booted into High Sierra on an external and again Nova not getting detected after a fresh Audirvana+ install.

Uplugged Nova ethernet and replugged and it's being seen.

Looking at Audirvana+ Blog page talking about 3 beta forum, it looks as though there are lots of compatibility issues:

Network players known to work (from your feedbacks)

Post by damien » Sun Jul 30, 2017 2:27 pm

This thread is meant to gather your feedback to list the network players working fine (or with minor limitations):
  • Bricasti M5
  • Devialet Silver Phantom (no DSD playback)
  • Kef LS 50 Wireless (no gapless playback)
  • Oppo BDP-105
  • Orange Livebox MediaCenter
  • Pioneer VSX-1131 (no gapless playback)
  • Pioneer N-70A (no gapless playback)
  • Sonore microRendu
  • Sonore ultraRendu
  • SoTM sMS-200
  • SoTM sMS-200ultra
  • Yamaha CX-A5000 (limited to 16/44.1 & 16/48kHz)
I'll maintain this list from your posts in this thread
 
(That was a few months ago)
 
Debug info below (edited):

Preferred device: Living room Model UID:Naim Audio Ltd. Living room UID:uuid:<edit>

Selected device:

UPnP device at http://192.168.1.198:43873/<edit>.xml

ID 0x0 Living room Manufacturer:Naim Audio Ltd.

Model UID:Naim Audio Ltd. Living room UID:uuid:<edit>

6 available sample rates up to 192000Hz

44100

48000

88200

96000

176400

192000

Volume control: No

Auto-detect MQA devices: No

Not a MQA device, user set to not MQA

DSD capability: Raw DSD (MSB)

Preferred stereo channels L:0 R:1

Channel bitmap: Ox3, layout:

Channel 0 mapped to 0

Channel 1 mapped to 1

UPnP/DLNA supported protocols:

http-get:*:text/xmlLNA.ORG_PN=DIDL_S

http-get:*:audio/vnd.dlna.adtsLNA.ORG_PN=HEAACv2_L2_320

http-get:*:audio/x-ms-wmaLNA.ORG_PN=WMAFULL

http-get:*:audio/x-ms-wmaLNA.ORG_PN=WMABASE

http-get:*:audio/3gppLNA.ORG_PN=HEAACv2_L2_320

http-get:*:audio/mp4LNA.ORG_PN=HEAACv2_L2_320

http-get:*:audio/l16;rate=48000;channels=1LNA.ORG_PN=LPCM

http-get:*:audio/l16;rate=48000;channels=2LNA.ORG_PN=LPCM

http-get:*:audio/l16;rate=44100;channels=1LNA.ORG_PN=LPCM

http-get:*:audio/l16;rate=44100;channels=2LNA.ORG_PN=LPCM

http-get:*:audio/mpegLNA.ORG_PN=MP3

rtsp-rtp-udp:*:text/xmlLNA.ORG_PN=DIDL_S

rtsp-rtp-udp:*:audio/vnd.dlna.adtsLNA.ORG_PN=HEAACv2_L2_320

rtsp-rtp-udp:*:audio/x-ms-wmaLNA.ORG_PN=WMAFULL

rtsp-rtp-udp:*:audio/x-ms-wmaLNA.ORG_PN=WMABASE

rtsp-rtp-udp:*:audio/3gppLNA.ORG_PN=HEAACv2_L2_320

rtsp-rtp-udp:*:audio/mp4LNA.ORG_PN=HEAACv2_L2_320

rtsp-rtp-udp:*:audio/l16;rate=48000;channels=1LNA.ORG_PN=LPCM

rtsp-rtp-udp:*:audio/l16;rate=48000;channels=2LNA.ORG_PN=LPCM

rtsp-rtp-udp:*:audio/l16;rate=44100;channels=1LNA.ORG_PN=LPCM

rtsp-rtp-udp:*:audio/l16;rate=44100;channels=2LNA.ORG_PN=LPCM

rtsp-rtp-udp:*:audio/mpegLNA.ORG_PN=MP3

http-get:*:audio/vnd.dlna.adts:*

http-get:*:audio/x-wav:*

http-get:*:audio/l16;rate=44100;channels=1:*

http-get:*:audio/x-m4a:*

http-get:*:audio/x_pm_flac:*

http-get:*:audio/l16;rate=44100;channels=2:*

http-get:*:audio/mpeg:*

http-get:*:text/xml:*

http-get:*:audio/aiff:*

http-get:*:audio/ogg:*

http-get:*:audio/x-dsf:*

http-get:*:audio/l16;rate=48000;channels=1:*

http-get:*:audio/l16;rate=48000;channels=2:*

http-get:*:audio/x-flac:*

http-get:*:audio/x-dff:*

http-get:*:audio/x-ms-wma:*

http-get:*:audio/m4a:*

http-get:*:audio/wav:*

http-get:*:audio/wave:*

http-get:*:application/ogg:*

http-get:*:audio/mp4:*

http-get:*:audio/aac:*

http-get:*:audio/3gpp:*

http-get:*:audio/flac:*

http-get:*:audio/vorbis:*

http-get:*:audio/x-aiff:*

rtsp-rtp-udp:*:audio/vnd.dlna.adts:*

rtsp-rtp-udp:*:audio/x-wav:*

rtsp-rtp-udp:*:audio/l16;rate=44100;channels=1:*

rtsp-rtp-udp:*:audio/x-m4a:*

rtsp-rtp-udp:*:audio/x_pm_flac:*

rtsp-rtp-udp:*:audio/l16;rate=44100;channels=2:*

rtsp-rtp-udp:*:audio/mpeg:*

rtsp-rtp-udp:*:text/xml:*

rtsp-rtp-udp:*:audio/aiff:*

rtsp-rtp-udp:*:audio/ogg:*

rtsp-rtp-udp:*:audio/x-dsf:*

rtsp-rtp-udp:*:audio/l16;rate=48000;channels=1:*

rtsp-rtp-udp:*:audio/l16;rate=48000;channels=2:*

rtsp-rtp-udp:*:audio/x-flac:*

rtsp-rtp-udp:*:audio/x-dff:*

rtsp-rtp-udp:*:audio/x-ms-wma:*

rtsp-rtp-udp:*:audio/m4a:*

rtsp-rtp-udp:*:audio/wav:*

rtsp-rtp-udp:*:audio/wave:*

rtsp-rtp-udp:*:application/ogg:*

rtsp-rtp-udp:*:audio/mp4:*

rtsp-rtp-udp:*:audio/aac:*

rtsp-rtp-udp:*:audio/3gpp:*

rtsp-rtp-udp:*:audio/flac:*

rtsp-rtp-udp:*:audio/vorbis:*

rtsp-rtp-udp:*:audio/x-aiff:*

DLNA 1.5: Yes

Gapless playback: Yes

Can play native DSD: Yes

Number of channels: 2

Use as stereo device only: No

 

 

So at least Gapless is theoretically supported!

What's the best route to contact Damien? Forum or is there a contact on the webpage these days? (I should have an old email from him if I can dig it out too).

I contacted the Audirvana team who suggested I send some logs regarding stability issues.

They suggested that it is probably the Nova failing to implement gapless via UPnP by buffering the upcoming track in advance.  It would be interesting to test with a different UPnP software.  I think Roon can be discounted as it uses the RAAT protocol recently added to the Unitis to allow them to work with Roon.

Pev posted:

My Nova plays gapless via UPnP on Asset from my NAS, via Roon, and via Tidal with no problem.  I haven't used Chromecast or Audirvana but I can't see how it can be a Nova/UPnP issue.

Thanks Pev, much appreciated.  My Nova does lossless from an old WD MyCloud Nas, I'm not certain if there's a difference between the Nova playing by 'pulling' from the NAS and an audio player 'pushing' a playlist to the Nova via UPnP.

There are so many permutations that troubleshooting can be bewildering!

I may need to take Tidal for a spin.

Likes (0)
×
×
×
×