Flashing Nac 272

I just received the years last upgrade, a Nac 272 bought via eBay. Unfortunately the Naim logo and display is flashing every other second. Its not loosing power, I can continue going through the menus when the display is on - its however not usable since I cant set it up. I have managed to restore factory settings, bit the problem persist. I have also tried turning it off for some time and removing and re-adding the link plug as well. 

Any suggestions or is it ”just” to locate the general agent in Sweden and send it to Naim for repairs? Not the best timing either, it will be a christmas holiday without stereo. 

 

 

 

Original Post
sjostrom posted:

I just received the years last upgrade, a Nac 272 bought via eBay. Unfortunately the Naim logo and display is flashing every other second. Its not loosing power, I can continue going through the menus when the display is on - its however not usable since I cant set it up. I have managed to restore factory settings, bit the problem persist. I have also tried turning it off for some time and removing and re-adding the link plug as well. 

Any suggestions or is it ”just” to locate the general agent in Sweden and send it to Naim for repairs? Not the best timing either, it will be a christmas holiday without stereo. 

 

 

 

The Logo should flash when mute is engaged.  You can un-mute from the handset but you can also mute/un-mute by touching the Naim logo and it is possible that this may be faulty.

Roger

Sjostrom, any way you can plug it in to your computer (usb) and router (network cable) and try to reinstall the current software from naim website? Can’t harm it if it isn’t usable anyway, and may work is software related.

 

for the record the logo doesn’t flash when muted, it goes off if this option is selected in the main menu when muted.

Likes (0)
×
×
×
×