Naim app updated and now refuses to run

I normally drive my Unitilite via the Android app from a tablet. This was going fine until I let the tablet update the Naim app as prompted recently.  My Android version is 4.4.2 and no system updates took place at the same time - just apps.

Now when I try to open the app, the screen blacks out and after a few minutes I get a message stating that the app has stopped working and do I want to Wait, Report or Quit. Only Quit appears to do anything. I uninstalled the app and downloaded it again from the Google Play store. When it is first run, it sees my Unitilite in my ‘Rooms’ view but when I select it, I get the ‘circle’ cursor which spins briefly then halts. At that point the app is effectively dead and my only option is to kill it off. Sometimes it locks the tablet completely with a hard reset being the only option. Subsequent attempts to run it just gives me the 'black screen' behaviour described above.

Just to test, I installed the app on my Android work tablet (it can’t stay there I’m afraid!) and it worked fine. Naim support suggested that I upgrade the Unitilite firmware, which I did so and it reported 100% success. Still no change to the problem unfortunately. I reported this back to Support and they appear to have gone in to hiding.

Could something corrupt be being left behind when I do the standard 'drag the Naim icon to the bin to uninstall' operation on the tablet? In other words, no matter whether I do a 'fresh' install, the app references corrupted data somewhere? If so, where could it be and how do I junk it? Has anyone else experienced a similar app problem?

Thanks in advance.

Original Post

I don't use Android normally but I remember from a Samsung phone I had from work that apart from uninstalling the app, you could alternatively delete all the data and cache contents associated with it. I used to use that to sort out the rubbish Outlook 365 app that used to slow to a crawl and crash every month or so.

You do that from the app manager.

best

David

Well I've tried both the suggestions offered but still no joy. I see that the app is shown as having had 10,000 downloads and I'm wondering if that's just a handful of users like me simply trying to get the damned thing to work properly.

I guess the next step is a factory reset of the tablet but I really shouldn't need to do that just because the app updated itself. And still no further word from Tech Support either. 

I suspect this is a network related issue to do with device discovery. The first thing I would try is a full network shut down and restart. Once everything is off (all devices on your LAN) start the router. When it's fully up, start the streamer, then the tablet, then see if they find each other.

Thanks, I'll try a LAN reset. What I don't get is why it works fine on my work tablet and that was a first time install. I've logged in to the router and there are currently no issues being shown, other devices are all working fine?

The firmware is 4.4 I believe. It's the one Tech Support pointed me towards and the most recent I'm told.

Thanks

Moggyman posted:

Well I've tried both the suggestions offered but still no joy. I see that the app is shown as having had 10,000 downloads and I'm wondering if that's just a handful of users like me simply trying to get the damned thing to work properly.

I guess the next step is a factory reset of the tablet but I really shouldn't need to do that just because the app updated itself. And still no further word from Tech Support either. 

Naim technical support's answering of emails quickly is a bit unpredictable, particularly if the guys are busy doing something else.  The Munich show this week is probably the culprit. You could ring them which will at least get someone to think about it on the spot. But this is almost certainly going to be an issue with your network, which is why there aren't hundreds or thousands of people reporting similar problems. I bet that resetting your router will fix the problem for you.

I mentioned in another thread that I am on a strange network at the moment and while everything works fine at home and had been working ok here for two days, I found my iPad suddenly couldn't see my Qb even though my iPhone could still and my Qb could see my Core. Restarting the iPad app and restarting the iPad made no difference. Unplugging the network connection to the Qb and plugging it in again a half minute later was sufficient to get my iPad to see the Qb as usual. Even though this affected one device and not the other, I am pretty sure this is a badly designed router which was my problem, not the Naim app nor the iPad nor the Qb.

best

David

Cheers Richard/David, I appreciate the assistance. I will try a router reset when I get home tonight and see what happens. I've 30 years in IT so I'm no stranger to the 'turn it Off/On again' method. Sometimes it works wonders!

Thanks

PS. Just as a side issue, what is the 'modern' equivalent of the Unitilite?

I think Phil may be away at the moment (possibly in Munich?) so contacting Naim directly may be your best bet.

Current replacement for the Unitilite is probably the Atom or Star.  I have to admit that the Atom seems to tick all the boxes without breaking the bank. I'm not sure how it compares in performance against the Unitilite though - best to listen to both Atom and Star to see for yourself.

To add to what Richard said, the Unitilite had a CD drive and you have to go to a Star if that's important to you. The Star can also rip CDs and put them onto attached storage.  So it's quite a different beast to the Unitilite.  The Atom is more like a UnitiQute 2 without FM/DAB. (The Unitilite may or may not have FM/DAB - it was an option.) But I think most people who are familiar with the UQ2 and have heard the Atom thinks that the Atom packs a bigger punch.

best

David

I've recently updated to the latest update 5.6 and lo behold...it won't work on my iPad. I've tried powering the iPad down and back up again to no avail. All I get is the background wallpaper in the app. Tried to use the email feedback facility in settings and this doesn't work either. Is there anyway I can uninstall and got back to my previous version as it worked fine. I have somewhere approaching 30 playlists and fear I will lose these if I have to delete the app. Does anyone know if my thinking is correct on this? I would add that I've updated each version of the app successfully before without issue. This is very frustrating!

Dady posted:

I've recently updated to the latest update 5.6 and lo behold...it won't work on my iPad. I've tried powering the iPad down and back up again to no avail. All I get is the background wallpaper in the app. Tried to use the email feedback facility in settings and this doesn't work either. Is there anyway I can uninstall and got back to my previous version as it worked fine. I have somewhere approaching 30 playlists and fear I will lose these if I have to delete the app. Does anyone know if my thinking is correct on this? I would add that I've updated each version of the app successfully before without issue. This is very frustrating!

Unfortunately Apple doesn't provide a way to go back to an earlier version of the app.  But 5.6 should work fine.

You can restart the app by double clicking the home button and swiping upwards. Then you just select the app to restart it. This doesn't delete the data associated with the app.

But I suggest you also look elsewhere. So turn off the router, any switch, the streamer and wherever your music is stored and turn it on again in the order router first (let it fully start before doing anything else), then network switch (if any), then the streamer and music store.

best

David

Moggyman posted:

I did the LAN reset as suggested - still no joy. Grrr. The tablet is seeing my PC and the Internet OK but not the Naim box 10 feet away from it. Well it sees it after I do an uninstall/reinstall but locks up as previously described. Baffled.

As it worked fine on your work device and none of the things suggested here have worked, I reckon it's an incompatibility between the app and your Android device/software.  So now I think you should ring Naim support and discuss. They will need to know precisely what Android device you are using with which build of the firmware.

best

David

If you do end up having to get another tablet then I recommend you go for an iPad. It doesn't need to be state of the art. At the moment it just needs to be running IOS 9.3 and it only needs wifi. It could be second hand and only used for controlling your HiFi.

The reason I suggest that is that Naim are usually a bit further ahead on the IOS app development than they are with Android and because the hardware is all the same, there is less risk of an unexpected clash such as you seem to have now.

best

David

I can see what you're saying but if I've paid a fair bit for the Naim kit in the first place, I'd expect better than having to replace a tablet because the Android app is a bit ropey. Just putting my software QA hat on for a moment,.....if the app doesn't do the Naim justice on Android then they should do something about it. I don't see why I should have to dip in to my pocket again just to get 2 Naim components talking to each other. Even second hand iPads are pricey. Still, we'll see what Tech Support comes up with and take it from there.

Thanks

Moggyman posted:

I can see what you're saying but if I've paid a fair bit for the Naim kit in the first place, I'd expect better than having to replace a tablet because the Android app is a bit ropey. Just putting my software QA hat on for a moment,.....if the app doesn't do the Naim justice on Android then they should do something about it. I don't see why I should have to dip in to my pocket again just to get 2 Naim components talking to each other. Even second hand iPads are pricey. Still, we'll see what Tech Support comes up with and take it from there.

Thanks

+1 

Klout10 posted:
Moggyman posted:

I can see what you're saying but if I've paid a fair bit for the Naim kit in the first place, I'd expect better than having to replace a tablet because the Android app is a bit ropey. Just putting my software QA hat on for a moment,.....if the app doesn't do the Naim justice on Android then they should do something about it. I don't see why I should have to dip in to my pocket again just to get 2 Naim components talking to each other. Even second hand iPads are pricey. Still, we'll see what Tech Support comes up with and take it from there.

Thanks

+1 

Now come on guys, don't shoot the messenger! I'm only telling you what I think, as another guy who has invested a lot of money in Naim kit!

best

Davif

Very disappointed with Naim App v5.6. On two iPads, one running iOS 9 and the other iOS 10, the app fails to work every couple of days. I have to delete the app and reinstall repeatedly. On an iPhone I have not experienced this problem. I am a big fan of Naim, having bought my first product in 1995 and now have two systems and 4 Muso Qbs. My patience, however, is being tested with this issue. I have carried out various tweaks, including shutting down my wifi network, but to no avail. For a high end manufacturer, I would have thought that Naim would be embarrassed by this faulty app and quickly release an update. I didn't have this problem with the earlier version of the app. The app is the gateway to using Naim streaming products but this just makes using the products tedious to say the least. I have a Uniti Nova on order, but am beginning to have a rethink!

 

Chris Hatten posted:

Very disappointed with Naim App v5.6. On two iPads, one running iOS 9 and the other iOS 10, the app fails to work every couple of days. I have to delete the app and reinstall repeatedly. On an iPhone I have not experienced this problem. I am a big fan of Naim, having bought my first product in 1995 and now have two systems and 4 Muso Qbs. My patience, however, is being tested with this issue. I have carried out various tweaks, including shutting down my wifi network, but to no avail. For a high end manufacturer, I would have thought that Naim would be embarrassed by this faulty app and quickly release an update. I didn't have this problem with the earlier version of the app. The app is the gateway to using Naim streaming products but this just makes using the products tedious to say the least. I have a Uniti Nova on order, but am beginning to have a rethink!

 

This is not an issue we saw in beta testing and the forum isn't full of people reporting this problem with the release. I run the v5.6 app on an iPad with IOS 9.3.5 and have never had to delete the app except when removing a beta that is being replaced by another one. And my app is successfully keeping track of four streamers, a Qb and a Core.

Naim can't issue an update if they aren't seeing the issue themselves. Have you reported it using the feedback option in the app? You also might want to ring up Naim technical support to discuss. Good luck in resolving the problem.

best

David

Update: I contacted Hannspree and they assured me that it isn't the tablet or the OS etc. I then contacted Naim and spoke to a helpful fella who asked me for all the details which he then forwarded on to their software guys with a view to getting hold of a Beta copy of a revised Android app. I haven't heard anything since but I work in the software business so I don't take the delay as anything unusual. It takes a while before software developers climb down and admit that something is actually wrong with their code. I'll keep hassling for the Beta copy and see how it goes.

Update: Tried a Beta release but that made no difference. Now waiting on another Beta. Pointless asking software developers when that'll be ready 

Having this app to drive an expensive piece of Naim kit is like buying a Golf GTi and finding out that it's fitted with a Dacia steering wheel. 

I gave up with a galaxy tab with naim app., which I originally wanted it for. the LAck of support with android has been rubbish,.  had  to purchase an ipad in the end, at more expense just to control the ndx.  years ago I started with sonos and its app is the one to beat...

Moggyman posted:

Update: Tried a Beta release but that made no difference. Now waiting on another Beta. Pointless asking software developers when that'll be ready 

Having this app to drive an expensive piece of Naim kit is like buying a Golf GTi and finding out that it's fitted with a Dacia steering wheel. 

Great comment. Sadly it is true.

It's just fate that the location of whatever streamer I get, has to be in a purpose-built cubbyhole in a brick facade in my living room - looks better than it sounds, honest. The trouble is that the cubbyhole is barely 6 inches off the floor, so reading the display is a hands & knees job. I used to run a Cyrus Streamline in there not so long ago. That had it's own remote including a small colour screen to drive the unit. There was an Android app for that as well but I can't remember ever using it. Then I got the chance of giving this Naim UnitiLite a home. I'd heard about Naim kit so jumped at the chance. All was well until they 'updated' the already clunky app.

I'm tempted to get the Cyrus out of its storage box and go back to that. I thought Naim stood for quality - good old fashioned well made kit. Maybe it still does stand for that but it's app can barely stand at all. Ebay is slowly beckoning.

Moggyman, just a thought. When you uninstalled the Naim app did you do so from within Google Playstore or using the Application Manager in Android Settings??  I experienced very similar issues to you when my Samsung tablet decided to auto-update to V2 of the app. I eventually uninstalled it via Application Manager, then restarted the tablet to help clear out any lingering files before re-installing it. I did this more in hope than expectation, but I'm pleased to say that it worked for me and its been running OK since although it sometimes takes ages to find my streamer. I do agree though, this app doesn't do the brand any favours! 

 

 

Chris Hatten posted:

Used to run Sonos across 4 rooms, then changed to Muso Qb. I agree Sonos is  reliable, user friendly app. The Naim app is chunky and not reliable. Still use Sonos for connecting Qobuz to my main hi fi.

just installed auralic mini with 2 tera internally installed using digital out.  this streamer is so close to my ndx... their app is stable and faultless. so it can be done

×
×
×
×