Naim app v.5.9 for iOS

I have just updated to version 5.9 of the Naim app for apple devices on both my iPhone and iPad. Wow! At last the problem of it hanging between selections has been resolved. This has been a problem over the last couple of updates, but normal functionality seems to have been resolved. Great job, thanks. 

Original Post

I had problems around version 5.8.2 which appeared to have an annoying habit of switching back to the home page between every selection. Sometimes it went back to the server selection page. After selecting the UPnP input it would flip back to the server selection page. Then after selecting the NS01 again it would switch back to the home page. Then I could select UPnP after which I'd see the page showing artist, album, genre etc. Then after selecting (say) artist, it would go to a blank screen with the spinning timer symbol. After several seconds it would show the list of artists. I would then select an artist and again get the spinning time symbol etc. On some occasions it would flip back again to the home screen. Fortunately this seems to have been resolved in version 5.9 which now responds immediately to the selection made - just as it used to.

 Can you check to if its the same as I have just found.    I have a touch sensitive area along the top of the now playing screen.    I'm on RP now playing screen,  along the top edge it has on the iRadio in the centre & X in the top right corner.   If you touch the screen anywhere along that top screen line it drops the now playing screen & goes to Home Screen,  just as you would expevt if you touched the X

If you confirm it it would be useful info  as I'm about to report it to the beta team as 5.9 is the last rev of current iOS beta.

Eloise posted:

I’m going to sound like a stuck record... but the UPnP browsing on the Naim app is still missing a “Home” / “Root” button.  When you have browsed 10 layers deep, having to press back 10 times is rather bad UI experience.

I agree, the button that takes you to the home page is all very well, but if it took you to the root of the UPnP menu it might be more useful.

My iPad has automatically updated the app to 5.9. I wish it hadn’t .... 

Since adding my NETGEAR nas the app has worked just about perfectly, 4 months or so with less than a handful of dropouts I guess. 

For the last week or so I have numerous times had the iPad /app jump back to start page from nas playlist, and some times I had to restart to be able to control the upnp playing again. Once or twice close and restart the app wasn’t enough, and I had to use the remote instead. 

Nothing else has been changed on iPad or in system. I have just restarted the router to see if this will help. If not, I tend to relate the issue to the app update, this being the only known change and the timing fits this explanation. I do however hope, and expect, the problems not being due to the 5.9. Update  

This leads me to the question: is it possible to avoid automatic updates of the naim app ? 

Even if the update turns out not to be the culprit then it would be nice to able to stay with a version that simply works. Similarly, is it possible to revert to an older app version ? 

Claus 

 

It is possible to turn off auto-updates. Go to settings>iTunes & App Store>Automatic Downloads. Then deselect 'Updates'.

I do not think it is possible to go back to an earlier release.

What you describe is very similar to the sort of behaviour which was resolved for me with version 5.9.

Thanks Clive, I have now turned off auto updates. 

I have yet to see if the router restart will solve my problem. I hope so, and that it was a coincidence that the issue started just about the same time as the new app version was released.  

Claus 

Still having problems with the iPad saying ‘ no Rooms found. ‘ And when finally connected it drops off again pretty frequently. 

However, it also seems that with my iPhone everything works fine !!

Both have app 5,9 BUT iPad runs iOS 11 and phone iOS 10,3,3,

Does app 5.9.have issues with iOS 11 for iPad ??

Claus 

Claus posted:

 

Does app 5.9.have issues with iOS 11 for iPad ??

Its OK for me,    app 5.9  iPad 9.7" iOS 11.2.2      NDX & all wired ethernet.   

I had the problem during the 5.9 beta testing,  app reset did not stop it repeating,  the most conclusive fix I found was to delete the app,  force restart the iPad (clears the RAM) & re-install the app.     I assumed the final release of 5.9 had solved it. 

The app is now working fine again (the last 3 hours at least). It finds the ND5 and it hasn't "logged out" while listening to music. 

Unfortunately I can't say exactly what cured the problem, since I updated IOS from 11. to 11.2.2. and while waiting for this to install I also shut down the router, the NAS and the ND5. The router and the NAS had already been turned off and on again several times, so I can't imagine this to have helped. But having the ND5 powered off might have been what fixed it, not the update to IOS 11.2.2. 

Whatever, it's working fine again now. Only drawback is that I lost my playlists (stored on the ipad) in the process. 

Thanks Clive and Mike for commenting.

Claus

Claus posted:

I lost my playlists (stored on the ipad) in the process. 

 

It used to be possible to restore playlists from an iTunes backup of your iOS device. Since an Apple software update at some stage, this option seems to have vanished. I'm pretty sure it is still there somewhere, buried in iTunes or iCloud, but I haven't had the patience to dig it up. It would be good to have a simple way to restore them, as they seem to be prone to corruption as well as sometimes vanishing during updates.

I prefer to manage and store playlists on my server, as this seems to be reliable, and backup/restore is easy.

Yeah, would be nice if the app could export the playlists to the NAS and import from there (on command maybe) as well. 

I hate to say that the ipad /app - NAS/streamer connection still isn't working perfectly. Sometimes the app returns to "Streamer home screen" and tapping UPnP to select tracks has no effect. Sometimes it goes all the way back to "App home screen" and starts searching for a "room" - which sometimes works, sometimes not. This can happen while the music is streaming from NAS.
It seems that logging in to the NAS in a browser and do a refresh in NAS system health helps the app to find the NAS/streamer again, can't say if this is consistent though.... For sure, closing and restarting Naim app doesn't always help. 

I can't say that the same has not happened at all in Nov and Dec, perhaps once or twice it did, if so I don't remember. But since end of Dec the Ipad/app  < > NAS/streamer interaction has been less consistent than the 2-3 months before (I've only had the NAS since september). 

Claus

 

Claus posted:

Yeah, would be nice if the app could export the playlists to the NAS and import from there (on command maybe) as well.

Using a Unitiserve means that you can create playlists on the same iOS device that runs the Naim app. Not quite as convenient as doing it from within the Naim app, but it's easy enough to flit between the two. To my mind, that small inconvenience is worth it to have playlists that are stable, and if they do crash, are very easy to restore from backup.

Well, yes, I wouldn't buy one just for that, even though used prices have dropped considerably. Maybe there's another server package that can do playlists and has iOS control? Maybe Roon can do it, as it seems to be good for metadata junkies, but that isn't exactly cheap either.

×
×
×
×