Partial loss of Naim-App functions – no streaming from NAS anymore

I face some problem on streaming music from my NAS via naim-App. While I can access the music directly via remote control on my Uniti 2, and while I can control, e.g., the CD drive or internet radio via naim app, I can not access the NAS via app.

Not accessing NAS seems not to be limited to a certain UPnP server as both installed (Synology, Logitech Media Server) show same behaviour: Display on iPad shows messages „Error. Skip track“ and then „Not playing“ (well, my translations). Simultaneously, CD cover is not shown anymore once an album has been added to tracklist (and switched corresponding view on naim app).

Reboot of NAS, UPnP server, Uniti or re-installation of naim app does not help. Does anybody is facing the same problem and/or has an idea what to do?

System-Info: Uniti 2, Naim App 5.9 on iPad mini 2 with iOS 9.3.5 (which is latest for that iPad), Synology NAS DS212+ with DSM 6.1.5 and Media Server 1.7.6 (both latest versions)

Regards, Kilian

Original Post

Well, at least I stopped and restarted the Synology Media Server once. However, the Uniti 2 does work with the UPnP server because I can select some songs using remote control and the Uniti itself (and having the Synology Server selected). Thus, for me, it does not look like a problem in the communication between Unit 2 and the NAS ...

The other thing to think about is whether anything auto-updated recently and might be the cause of the problem.

For example your NAS operating system. I'm not an expert on them at all but from time to time Synology in particular do seem to give people pain by changing something that requires the Naim user to go in and do stuff to it to get the music flowing again - a main reason why I use a Core and not my relatively new Synology NAS which has been switched off for a couple of months now waiting for me to get round to selling it on.

best

David

Good point David,  I recall the problem about a year ago with the older one bay small CPU units.     Personally I've never seen a problem with my 214.    They released DSM 6.1.5-15254 a week or so ago followed by a new MS 1.7.7-2855 yesterday.    Both are working perfectly for me.   

Hi

both DSM (6.1.5-15254) and MS (1.7.6 - 2482) are shown to be latest versions,

@Mike-B: Different versions may come from different ARM processors installed - the DS212+ uses ARMv5, while the 214 uses ARMv7. (Note; for same reason I can not install asset media server because workaround for Synology does not apply for ARMv5 processor)

I did re-index on NAS twice. First with video, photo and music folders, second with just video and music (as I not really stream photo, but videos on my TV). Result is almost in both cases the same: I can not stream from app. For accessing directly from Uniti: for a) Synology media servernot working with Message "wrong data format", but all files are in *.flac and should be recognized as valid format. Logitech server seems to work (but again, not from app)

@Adam: On both app and Uniti directly, I see on root the NAS with its name, which I understand to be the media server of Synology. Basically because I do see Logitech media server on same level (not sure if this is answering you question).

By the way: I can see the CD covers on the app, however, if one is selected by, e.g., via view "all songs" or via "album-view", the song does not start.

So, I tried all what you recommended - thanks for that - but unfortunately I didn't work :-( ... And I have to admit that I running a little out of ideas. Anybody an idea how to go on?

Kilian,  I'm running out of ideas,  I don't understand why its giving the "wrong data format" message,  I need to have a think.    I'm tempted to suggest to go for the old IT trick of turn it all off & start again and in addition please delete the app. 

Restart in sequence, one at a time & let each restart complete before starting the next.  First broadband hub (router)  then NAS,  then Naim, then re-install the app & try that.  If it works,  then restart Logic (why do you have Logic ??)

Have you tried uninstalling and reinstalling the Synology Media Server?

Have you tried doing a full sequential reboot of all your network components Router / (seperate WAP if used) / (seperate Switch if used)?
Restart the Router first then work outwards to other components (switch, WAP, NAS, computers and finally the Uniti).

Are you using DHCP or are you configuring the network manually using static IP addresses (if manual, can you try reverting everything to DHCP?)

I applied the complete restart as described by Mike-B this morning. And afterwards it looked that everything is working fine again (this morning). But, well, this evening I wanted to run a longer test, and faced the same inital problem as before. Even what I have done this morning was not working anymore, and I haven't done anything inbetween as I was at work. Nevertheless, the message "wrong data format" did not appear again.

I'll be on a business trip until end of the week, so right now I can not further investigate. My plan - so far - is to deinstall Media Server, restart of whole system, install Media Server, run index, restart of whole system again.

@Mike-B: I have Logitech because I also have a Squezzebox running.

@Mike: Network address is static. But, to be honest, I don't know what you mean by reverting everything to DHCP. Info: Router is a Fritzbox 7390. NAS is directly connect to Fritzbox, Uniti via Switch to Fritzbox - the switch is also used for the TV and my PC, which is placed in an adjacent room. I do not use any WLAN except for iPad, on which the naim app is installed, and for smartphone(s) and business laptop.

If anyone of you have additional ideas what to do, I'll try on weekend for sure!

Kilian says "to be honest, I don't know what you mean by reverting everything to DHCP"  so I don't expect the Fritzbox has been changed from DHCP which is the factory default,  but if that setting has been changed,  it needs to be changed back.  DHCP on the whole system is where it needs to be.   

I'm not that hopeful but the next weekend plan to uninstall Media Server, restart of whole system, install Media Server, run index, restart of whole system again will be good to get done.    After that I fear it might be component changing time & I would start with the router.   

Ok, what happened:

  • First task with all this re-boot and re-install things did not change anything. Info: After reinstallation of Synology MS re-index was started also automatically.

  • Direct connection of Uniti to router, i.e. by-passing switch, yield in working system … well just in the very beginning. After some hours without having anything than just not listening to music, Uniti failed to connect to NAS again.

  • I changed quite a lot things in how to connect Uniti, NAS, and router together and was not able to found some pattern, i.e. that would indicate a physically failed unit.

  • I observe in increasing number of events during which the Uniti initializes its inputs, sometimes even during playing radio from internet.

  • During one phase of testing, Uniti connected to network in original configuration, I switched between internet radio and NAS back and forth. While making switch to NAS I could see some connecting sequence being reported to Uniti's display – unfortunately not reproduciable, i.e. after hooking up a camera pointing at the display for documentation purposes it did not appear again - but Uniti show old, not functioning behaviour.

Finally, I picked up an old Roko Soundbridge and installed on same switch than the Uniti. Since the Soundbridge can't play *.flac files I stored some *.mp3 on NAS. And well, here it got interesting (note that with additional mp3 files there exist two(!) files of the same song on NAS):

  • Soundbridge uses Synology Media Server as well. Streaming *.mp3 files was working without any problems

and on Uniti, controlling via App:

  • *.mp3 and *.flac on different folders on NAS. However, Naim App shows both files in same (album-) view, i.e. when whole album is streamed every song should be played twice: once the mp3 and once the flac. BUT only streaming of MP3 was fine while FLAC was skipped with message on Uniti's display „Error, track skipped“ (my translation)

  • To check if *.flac files might have been got corrupted, I ripped three songs of a CD again, but changed some artist information to have a new folder on NAS. This time, both *.flac *.mp3 where stored in same folder (using dbpoweramp for ripping). Here same result: MP3 is streamed while FLAC is skipped with error message.

So, to conclude, I was not able to find a physically damaged unit by modifying network set-up. But latest test is totally confusing to me because Uniti was able to stream MP3 but not FLAC while nothing has been touched or changed during test. Uniti just skipped the FLAC on his own and continued with next MP3 until end of album … what is going wrong here?!?!??

Final remarks:

  1. I can play flac-files from PC.

  2. On Fritzbox-Router DHCP is activ with default parameters.

@Mike-B: I haven't changed router yet, mainly because I gave my old one away...

Some more remark (I getting crazy ...)

I just switched Uniti off, used the ethernet cable connected to the Soundbridge for the Uniti and turned Uniti on again (while all other stuff, i.e. switch, NAS, router was powered) ... and Uniti was able both MP3 and FLAC. The I switched back to the ethernet cable used for the test just described above, and now Uniti does play both MP3 and FLAC ...

I even have no idea what to test with my Naim dealer, except that they try to use the Uniti for longer time and see if temporarily (d)effect shows up as well...

 

OK, try rolling a six sided die six times (you need to decide to do all 6 rolls before starting the test or it won't work):  If it comes up 6 on all occasions then you probably have a poltergeist! 

Alternately you may have a suspect network cable and moving the cable 'cleaned up' an internal connection that was making poor contact!

Kilian, as you are checking all factors:

1. Have you activated the “buffering” indicator on your Uniti screen to check the buffering pattern when tracks are not playing?

2. I would turn on and off the router and try again (if not done yet)

3. I would re-apply the Uniti’s firmware

4. Finally, I would set up an alternative WiFi. When my provider switched to VDSL a few years back I discovered I had issues controlling the NDX from the iPhone. I disabled the WiFi on my modem and delegated WiFi duties to an Airport Express. This has benn working nicely for the past years. This takes some effort to set up but if you can borrow an AE it’s worth trying. 

Well, right now it is working (don't know for how long). Nevertheless, I checked for Poltergeist and challenged him a little to roll just several 3. No kidding, the very first one was one ... oh, oh ... then a six (at least two times three) ... but then the line finished. Uff.

So far, another ethernet cable to Uniti is installed on different output of switch. Will see.

@DrPo: 1) buffering indicator will be checked, when it is not working again (but since the flac-file was not even started all other information (artist, ...) was not displayed as well). 2) done already several times. 3) will take a little more time to do, same for 4) as I need to get WiFi antenna out of some well-stored box in the cellar first.

Will check if I can borrow some router as well, but this will take time as well.

@Huge: When the Uniti was directly connected to the router I used a different cable already on different input of the router. Without success...

Dear all

after some weeks of silence (I got knocked down by influenza virus) some update on my attempts to get the Uniti playing FLAC-Files:

- Firmware re-installed

- Instead of WiFi (as I'm not using it) I changed connection between NAS and Uniti from NAS - Router - Switch - Uniti to NAS - Switch - Uniti by means of patch cable

Both measures no improvement.

Then I conntacted synology forum (both german and international one). So far, I got answers in german forum only (for whatever reason). Discussion is still ongoing, but for those who understand german may have a look here: http://www.synology-forum.de/s...-MP3-aber-keine-FLAC

Info: I installed BubbleUPnP - App on my mobile phone, locally stored some FLAC file, and configured the Uniti for being the "renderer". I.e. I bypassed the NAS . However, same effect, Uniti is playing MP3 but no FLAC.

And, well, there is some remarkable thing:

In case I directly access the NAS from the Unit itself, i.e. not via an App, I get the message "Wrong file format" in Unit's display. Simultaneously I can play the FLAC-Files via VLC media player on my PC.

Does anybody have some thoughts on that?

Have nice eastern

Kilian

Kilian posted:

And, well, there is some remarkable thing:

In case I directly access the NAS from the Unit itself, i.e. not via an App, I get the message "Wrong file format" in Unit's display. Simultaneously I can play the FLAC-Files via VLC media player on my PC.

Does anybody have some thoughts on that?

Have nice eastern

Kilian

It’s hardly remarkable - it’s quite logical. Naim streamers are designed as renderers - music needs to be ‘served’ to them via a UPnP server. The only exception is the USB input, where files can be played directly from the memory stick.

 
What you’ve described above is the exact opposite to what should be done.

 

 

 

One idea (as VLC Player plays the files OK I would focus on the Uniti itself): try to play on the Uniti FLAC files from your NAS using a different app like mconnect lite (free on iOS). If they play (and the app shows the bit rate so you can check its FLAC indeed) then you know that the player “part” of the Uniti is OK. As this is an all in one player combining server renderer and DAC functions it’s difficult to understand where the issue may lie. 

Well, what I tried to say by "directly accessing NAS from Uniti" is that I used the key field on the Uniti itself to select the NAS as source, the server (on the NAS) and then browsed through logical structure to my prepared test-album which both contains MP3 and flac-files.

@Huge:Trancoding is off.  But I can not select to convert a specific source format into a specific output format; and I just can select FLAC/APE, ALAC/AAC, OGG and AIFF ... but

I found my WLAN-antenna and gave her a try. Well, network-connection was quite unstable, but Uniti started playing FLAC-files (for seconds at least). I got confused ... switched the Uniti off, disconnected the antenna, connected LAN-cable again, switched the Uniti on ... and it is not playing FLAC files for 30min ... so will keep the trancoding option in mind (right now I enjoy my music) ... I don't consider the problem as solved, I experienced this behaviour as just temporarily in the past.

Well, it was working for two days without faults. Nevertheless, I hesitated to report it here as I had no glue what has changed. And, with inputs from synology forum, I share DrPo's view that it is, finally, a problem with the Uniti - because Uniti just stopped playing FLACs again.

USB was ok, playing both MP3 and FLAC

@HUGE: No, no problem with WAVE files. Except that my NAS hasn't sufficient diskspace left to run the conversion. Nevertheless, I will create some test-files just to see. But, despite of that, I don't understand why the Uniti plays MP3 without problems at all while FLACs are refused - it is just a data stream, isn't it? That doesn't make any sense to me.

When they get to the Uniti, MP3, FLAC and WAVE are indeed just data streams, however they use different decode algorithms, and the differences are handled by the UPnP Media Renderer component in the Uniti.  It could be a failure at this point; but it could also be a failure in the Media Server on the NAS if that were to return incorrect format information to the Media Renderer or Control Point (i.e. the UI application used to select the items to play).

Add Reply

×
×
×
×