Backing up Unitiserve to QNAP NAS - here we go again...

Hi everyone,

I've just bought a QNAP TS231P w/2x2TB WD Red drives to use as back-up for my Unitiserve.

Despite not being that much of a tech-head, I've managed to install the NAS drive and create back-up folders, as described in the Naim how-to guide.

So far, so good.

Having done the easy bit, I'm now struggling to get the US to link to the NAS and to set up regular back-ups.

Using a Mac and the online display interface home/system/music stores/add music backup, I can see the folder that I want to back the files up to (which is marked as Disabled), but when I try to add it I get the error message "Unable to convert share to music backup", with no further options of what to do.

Have spent the last three evenings trying to sort it out, but have drawn a blank and am starting to wish I spent the £350 on vinyl instead of the NAS.

Having read some of the horror stories on here, I fear I may be entering a whole world of pain, but any help/ideas you might have to get me backing up successfully would be very gratefully received. 

Many thanks in advance.

 

 

Original Post

I could probably scratch my head and come up with the solution to this, having sorted it before, but to save yourself further hassle, just phone Naim support and they will be able to sort it for you. Phil Harris knows this stuff inside out, and will either be able to tell you what to do, or do a remote log in and do it for you.

Once it's set up, the backup is totally automated and it just happens, no further action or knowledge required.

If you use the downloads folder, remember that you need a separate backup routine for that, using a separate folder on the NAS.

I agree that Phil is the guy to ask. He remoted in to set up my Synology NAS to backup my Unitiserve when I ran into the greyed out box problem. But you need a PC for him to remote into. He can't do it with a Mac.

I think to be promoted to a store or a backup folder, the folder in the NAS has to be completely empty, including that it mustn't even have an empty waste bin in it. So that could be something to look  at.

best

David

I think you will find that the problem is that the folder you want to use needs to be absolutely empty. When created the folders sometimes have a trash, deleted or similar file/folder and this must be deleted to use the folder as a back up. Open the folder and see what is in there and delete if necessary, should work then..

Thanks for the advice re. deleting the empty trash folder. This has allowed me to set up a Music Backup in the Naim desktop client.

What I need to work out now is how to start my first back-up and set up a regular weekly/monthly back up to the QNAP.

Presumably I do this via the NAS drive desktop, but I can't find anywhere on the Filestation app or in the Control Panel that would allow me to do this.

I can see the folder in Filestation and the permissions are set to read/write/execute, so can't think of anything else that could be wrong.

I'm probably being a bit thick, but do I need to download another app from the QNAP App Center, or am I missing something obvious?

Feel like I'm tantalisingly close to cracking it, but not quite there yet...

 

If you haven't done it already download the Nserve app to your MAC.

Open the App and open Maintenance from the dropdown list next to your Userve address in the top left hand corner - the default you will see is Library.

Open Backup Scheduler and click on add and complete the add/edit backup pop up window and Robert as they say is your uncle!

Thanks everyone.

Switching to n-serve solved the problem without having to bother the lovely people at Naim Customer Service.

All that switching between apps is not the most intuitive thing in the world, but we got there in the end.

Now I just have to remember how to do it all over again to back-up the Downloads folder...

...and face the daunting prospect of putting 1200 CDs on eBay...

 

Second that re Phil who remotely set mine up a while back. I had a similar issue when I switched a a Core a couple of weeks ago. Migrated everything from the Serve without issue but try as I might I couldn't get the backup to work. Trevor rode to my rescue in Phil's absence when on well deserved leave. Trevor fixed in 10 minutes what I'd been fiddling around with for hours. I'm sure he won't thank me for mentioning it though!

I had the same problem with my QNAP and solved it:

The problem was caused by hidden files in my backup folder.  The folder must be empty to set it up as a backup folder. 

Open the backup folder in QNAP's file station.  In the top right of the screen there are three vertical dots.  Click these and select > "settings" > "show hidden files."  Then "close" .  Select the newly revealed files and right-click and delete them.  They will be put them in a new recycling bin.  Delete the recycling bin as well.    

Go back to the Naim UnitiServe web page and setup the backup folder from the "Music Stores" page.  I found the application didn't find the backup folder I had set up as a share in the "add new music backup" page.  I found it best to "enable" the backup folder as a share and then "disable" it.  When it is disabled the folder appeared as a shared folder in the "select share" page. 

 

I hope this helps.

Likes (0)
×
×
×
×