HDX can see files but not play

I have an HDX attached to a LAN network on which is a NAS drive.  

On my laptop and on my App I can see all the music on that NAS drive.  It is currently set as a Network Share.  When I try to Use as Store it produces the error

Invalid Operation 'cannot authenicate share "\\\Music"'

When I try to play a disc I get the error message "Hard disk player is currently busy.  Please try again." or "Play request failed" on the App

The HDX has taken IP address

My computer has address showing

The router is as usual

I have switched off my Firewall to make sure that isn't causing the problem.

Can anyone suggest what I should be doing to rectify this?

I have already turned everything off and rebooted one by one (routers, then HDX then NAS drive.



Original Post

Your NAS should be set as a "Share" and also "enabled".
If you're not sure it's "enabled" follow the below:

Using the N-Serve desk top client on your computer, click on your HDX at the top left (mine comes up as NSHDX49F5), then select "Maintenance", then below under "Music Repositories" click on "Network Shares".

This shows a list of Music Shares and also if it's status and if it's enabled and active. 

I have some disabled on mine, such as my iTunes library which I do not want as it duplicates some of my music and are all mp3's and such like. I also don't want other computers on the network sharing their rubbish music so I disable them from the HDX shares list.

If this link actually works, it should show in the second picture. I have tried and tried but cannot make a single picture link work - I think it's since photbucket updated something as I used to be able to do it!


If you've got into "Maintenance" I guess you've already clicked on your HDX at the top left, otherwise you'd still be in your HDX "library"


Not a nuisance at all. I just wish I could show the picture - a picture paints a thousand words, so they say.

If you're in "Maintenance" you need to click on "Music Repositories" then click on "Network Shares". On my Mac version, these tabs are on the left side of the N-Serve window.
The Network shares are then listed, with all of their details to the right of them. Each one shows its status and can be adjusted by further actions to the right of the window. These include "Host Scan"  "Re-scan"  "Ignore" and "Activate" amongst others.


I got my NS01 back from a repair/service a few weeks ago and when I tried to set it up had issues. The shares on my NAS were available and I could connect to them using my laptop using both Windoze and Linux, however the NS01 wouldn't - with those error messages. Digging around found a post by David Dever, I think, who had similar issues. As a result I set both my laptop and NAS to be a part of the Workgroup 'NAIM', and things then worked.

Thanks David by the way.

Hope this assists.


Likes (0)