Kazoo & Bubble upnp loses 272 renderer

I am using Linn Kazoo on windows to control my 272, and bubble upnp does the transcoding and proxying. Often Kazoo looses connection to the 272 - i.e. it cannot see the 272 renderer. It seems to correspond with the computer running Kazoo sleeping (it loses connection after I wake it up) and the only solution I have found is to restart the bubble upnp server. Then everything works again. Is there any way I can stop kazoo losing connection with the renderer?

I am lost for ideas, so any help will be gratefully received.

Original Post
sjt posted:

I am using Linn Kazoo on windows to control my 272, and bubble upnp does the transcoding and proxying. Often Kazoo looses connection to the 272 - i.e. it cannot see the 272 renderer. It seems to correspond with the computer running Kazoo sleeping (it loses connection after I wake it up) and the only solution I have found is to restart the bubble upnp server. Then everything works again. Is there any way I can stop kazoo losing connection with the renderer?

I am lost for ideas, so any help will be gratefully received.

You should probably run Bubble UPnP Server on a device that is on 24/7. I have an instance of Bubble UPnP Server running on a Raspberry Pi. It has been running for about two years without problems. I reboot the Pi every few months.

If you have an Android mobile device, you may find that Bubble UPnP (the Android app, not the server) is more stable than Linn Kazoo.

Thanks for this - running bubble server on a raspberry pi is certainly an option worth looking at. At the moment bubble is on a NAS that stores the music so splitting it off may well help. I have been looking for an excuse to buy a raspberry pi!!

I would prefer a windows based controller because I routinely have my laptop on my knees and like to control the music using that, and annoyingly kazoo seems to be the only option for windows.

Which NAS is it where BubbleUPnPServer is running on? I had it on a Synology DS213+ that was able to deep sleep (what current Synology NASs are not capable of) and did not have such problems. The only problem of this device was that Bubble became too slow after playing some tracks. With a newer DS418play (with faster CPU and as I think most important: more memory) it works much faster.

If you restart the bubble server does it take a while (1-2 minutes or more) until it finds your streamer? Or does it work in about less than 30 seconds again? If it takes longer it may be an IGMP problem so that broadcast packages are lost. Maybe this also has to do with loosing the streamer after the NAS went to sleep?

Do you switch off the streamer, too? 

If you turn off the streamer it might get a new IP address on startup. It could be a good idea to configure your router (that manages the ip addresses for all devices in your LAN) to always hand out the same ip address to your streamer.

I run Asset on a QNAP NAS and Bubble runs on a Pi. I found this gave better sound quality than running it all on the QNAP. 

I've set Bubble to transcode Tidal to WAV as I prefer this to FLAC.  I find Tidal to be very good using this setup; pretty much like local streaming.

50 quid for a brand new Pi3+ πŸ˜€

gert posted:

Which NAS is it where BubbleUPnPServer is running on? I had it on a Synology DS213+ that was able to deep sleep (what current Synology NASs are not capable of) and did not have such problems. The only problem of this device was that Bubble became too slow after playing some tracks. With a newer DS418play (with faster CPU and as I think most important: more memory) it works much faster.

If you restart the bubble server does it take a while (1-2 minutes or more) until it finds your streamer? Or does it work in about less than 30 seconds again? If it takes longer it may be an IGMP problem so that broadcast packages are lost. Maybe this also has to do with loosing the streamer after the NAS went to sleep?

Do you switch off the streamer, too? 

If you turn off the streamer it might get a new IP address on startup. It could be a good idea to configure your router (that manages the ip addresses for all devices in your LAN) to always hand out the same ip address to your streamer.

Thanks for the reply - much appreciated. My replies:

The NAS is an HP proliant microserver - I can't remember the model number but its effectively a mini-ITX motherboard and a PSU in a box that can house 4 disks. I don't experience any performance problems transcoding on this.

I would say that when I restart bubble it is 1-2 mins. I remember reading that IGMP could cause problems, so I switched it off on both my network switch and modem router. I don't really understand IGMP, but switching it off hasn't had much effect.

No I don't switch off the streamer. The 272 and the NAS both have static IP addresses issued by the modem router.

The annoying thing is that the losing contact problem appears intermittent - if the laptop where I run kazoo sleeps for a short time, often it re-establishes contact when I wake it up.

Its very annoying - apart from this, everything works well and sounds very good! I just lose control every now and then!

Guinnless posted:

I run Asset on a QNAP NAS and Bubble runs on a Pi. I found this gave better sound quality than running it all on the QNAP. 

I've set Bubble to transcode Tidal to WAV as I prefer this to FLAC.  I find Tidal to be very good using this setup; pretty much like local streaming.

50 quid for a brand new Pi3+ πŸ˜€

I am very tempted to get a pi!

Oh, I think I have misread the initial discription. The problem is not that bubble loses the streamer (you can check if it is still listed in the renderer tab of bubble) but kazoo loses contact to the bubble proxy.

It is really the question if installing bubble on another platform like the pi3 would help then? Do you have any mobile device where you can install lumin or kazoo or the bubble app (not server) to check if it does lose the bubble proxy, too, if the laptop's kazoo did loose it?

gert posted:

Oh, I think I have misread the initial discription. The problem is not that bubble loses the streamer (you can check if it is still listed in the renderer tab of bubble) but kazoo loses contact to the bubble proxy.

It is really the question if installing bubble on another platform like the pi3 would help then? Do you have any mobile device where you can install lumin or kazoo or the bubble app (not server) to check if it does lose the bubble proxy, too, if the laptop's kazoo did loose it?

Yes thats right - its the kazoo losing contact with bubble proxy - sorry if I wasnt clear in the OP - I wrote it in a bit of a hurry.

I do have kazoo on an android tablet, but I dont use it much because I use the laptop. I will give it a try however to test.

Your previous comment about IP address leasing has got me wondering - I haven't fixed the IP address of the laptop running the kazoo client, so it might be that the IP address changes when it sleeps for a while. This sounds plausible to me as a cause of the problem! I will try fixing this IP address as well and see if that makes any difference.

Good luck!

On android I really recommend the bubble upnp app for streaming qobuz via the bubble upnp server. It works here better than lumin and kazoo on iOS. Lumin and bubble do show the new releases in more detail (more albums per genre) than the kazoo app. But I do not know the kazoo PC application.

sjt posted:
gert posted:

Oh, I think I have misread the initial discription. The problem is not that bubble loses the streamer (you can check if it is still listed in the renderer tab of bubble) but kazoo loses contact to the bubble proxy.

It is really the question if installing bubble on another platform like the pi3 would help then? Do you have any mobile device where you can install lumin or kazoo or the bubble app (not server) to check if it does lose the bubble proxy, too, if the laptop's kazoo did loose it?

Yes thats right - its the kazoo losing contact with bubble proxy - sorry if I wasnt clear in the OP - I wrote it in a bit of a hurry.

I do have kazoo on an android tablet, but I dont use it much because I use the laptop. I will give it a try however to test.

Your previous comment about IP address leasing has got me wondering - I haven't fixed the IP address of the laptop running the kazoo client, so it might be that the IP address changes when it sleeps for a while. This sounds plausible to me as a cause of the problem! I will try fixing this IP address as well and see if that makes any difference.

Good luck but I do not think that a fixed IP address will solve the problem. Try the Bubble UPnP app on the Android tablet. Does the problem persist?

OK - I got back from my trip last night and I thought I would give fixing the IP address of the controller laptop a try, and when I went into the router settings, I discovered I had not fixed the IP address of the 272 either. I fixed both of these to static IP addresses, and the whole thing seems much more robust now - I did this over 24 hours ago, and I have been using it most of yesterday evening and today, and no sign of Kazoo losing the 272! In total, the NAS, the 272 and the controller have fixed IP addresses now.

Guinnless posted:

Static IPs are not the solution and can cause issues if you have not configured any DHCP controller correctly. Is the laptop using wireless?

Yes the laptop is wireless and the rest is wired. The DHCP server is in a TP link modem router. This is connected to a netgear switch that joins the NAS and the 272 together. Can you tell me why static IPs are not the solution? I'm not questioning the comment, I just want to understand. Also, if you could tell me what I shouldn't do when configuring the DCHP server? I must confess I have used static IPs for ages with no apparent problems, so I am intrigued by the comment.

Your router will have a set range of DHCP IP addresses for allocating to the various devices on your network as they join it e.g. by being switched on or having their IP address lease renewed. If you reserve a device’s IP address within the DHCP range and the device is then taken offlne you might find that its reserved address has been assigned to another device on the network. 

On my router the DHCP range runs from 192.xxx.x.64 to 253 so if I reserve an IP address for a device e.g. a server on 24/7 then I give it an address below this range e.g. 192.xxx.x.50.

sjt posted:
Guinnless posted:

Static IPs are not the solution and can cause issues if you have not configured any DHCP controller correctly. Is the laptop using wireless?

Yes the laptop is wireless and the rest is wired. The DHCP server is in a TP link modem router. This is connected to a netgear switch that joins the NAS and the 272 together. Can you tell me why static IPs are not the solution? I'm not questioning the comment, I just want to understand. Also, if you could tell me what I shouldn't do when configuring the DCHP server? I must confess I have used static IPs for ages with no apparent problems, so I am intrigued by the comment.

The DHCP server will most likely have a range of dynamic IP addresses defined e.g. 192.168.1.64 - 192.168.1.254 and will serve up IPs for the hosts requesting it, it also provides DNS and Gateway IPs for the associated host.  If you were to set a static IP you'd need to make sure it wasn't one of the ones in the DHCP Scope, and also to ensure that you assigned the correct DNS & Gateway IPs.  DHCP is well proven technology and should be all that's needed in a  'normal' home environment.

The only devices I have with a static IP in my setup is my Ras Pi and WAP[1].  Everything else including the ND5XS, QNAP etc gets a DHCP allocated one.

[1] and this is just for ease of logging on - it has no effect on how the network works.

sjbabbey posted:

On my router the DHCP range runs from 192.xxx.x.64 to 253 so if I reserve an IP address for a device e.g. a server on 24/7 then I give it an address below this range e.g. 192.xxx.x.50.

I used to do the same,  but that was back 2 or 3 years ago, I found it overcame some network discovery issues we had at that time,  forum & other advise said it was the thing to do.  On my last hub I set it to DHCP after taking advise from an IT professional & reading up a bit more,  and have to admit DHCP is easier - easier in that I did nothing & let the hub take the strain of the brain-work - & it did not show the same discovery problems I had seen in the past.   My current hub is a BT HH6 I have it all set for DHCP,  & it keeps the same IP address numbers as I used for static in the past, it seems when it was new it just adopted the device IP numbers that were assigned to each MAC address & has kept them.

The question is if SJT really has used static IPs. For me it sounds like he only advised the router's DHCP server to always use the same IPs for the two devices. Ir he had used really static IPs he had to configure the streamer and laptop to use a static IP and not to use DHCP.

Advising the DHCP server to always assign the same IP is not a bad or problematic thing.

gert posted:

The question is if SJT really has used static IPs. For me it sounds like he only advised the router's DHCP server to always use the same IPs for the two devices. Ir he had used really static IPs he had to configure the streamer and laptop to use a static IP and not to use DHCP.

Advising the DHCP server to always assign the same IP is not a bad or problematic thing.

Yes thats it! Sorry if I used the wrong phrasing - I go into the router's control page and tell it to use the same IP address for a connected device identified by its MAC address.

Thanks to all for the replies

Guinnless posted:

I run Asset on a QNAP NAS and Bubble runs on a Pi. I found this gave better sound quality than running it all on the QNAP. 

I've set Bubble to transcode Tidal to WAV as I prefer this to FLAC.  I find Tidal to be very good using this setup; pretty much like local streaming.

50 quid for a brand new Pi3+ πŸ˜€

To return to an earlier theme about the raspberry pi running bubble server - I am very interested in this, as I have the bubble server on the NAS and if better sound can be had its a great excuse to get a pi. Would you mind answering a few questions? 1) what operating system are you using for the pi? 2) what power supply do you use for the pi? 3) any notes on how the sound is better would be appreciated. Thanks!

1) Pi is running "Stretch"Lite

2) I bought the Pi as a complete kit including case and PSU

3) I originally did a test with Bubble on an old laptop and Tidal was much closer, if not the same. I then did the install on my QNAP and did the same again and found that it wasn't as good. Checking my QNAP I discovered that it was running low on memory which probably caused the SQ issues (my QNAP only has 1GB). Hence the purchase of the Pi.

This setup suits me as QNAP is "standard" and only lightly loaded. And I have a quality boost using Bubble 😊

I've just updated 'ffmpeg' to the latest version and the track changes are more responsive.

Guinnless posted:

1) Pi is running "Stretch"Lite

2) I bought the Pi as a complete kit including case and PSU

3) I originally did a test with Bubble on an old laptop and Tidal was much closer, if not the same. I then did the install on my QNAP and did the same again and found that it wasn't as good. Checking my QNAP I discovered that it was running low on memory which probably caused the SQ issues (my QNAP only has 1GB). Hence the purchase of the Pi.

This setup suits me as QNAP is "standard" and only lightly loaded. And I have a quality boost using Bubble 😊

I've just updated 'ffmpeg' to the latest version and the track changes are more responsive.

Great, thanks. I'm glad to hear that the standard PSU is OK, as the "better" ones are expensive. I'm off to the pi shop. Thanks again!

Guinnless posted:

Static IPs are not the solution and can cause issues if you have not configured any DHCP controller correctly. Is the laptop using wireless?

Quite, if you need to use designated IP addresses, the usual correct way is to assign in DHCP.

if addresses are getting lost, then it points to a fault in the home network or home network applications.

However there is by a standard a fail safe, and DHCP should check to see if anything answers to a specific address before it assigns a host to that address from its pool defined in its scope. The issue can arise of course if the device using an address from the pool  is powered off.. hence always best to assign in the DHCP configuration.

Right, I have just checked in my router - what I have been using to fix IP addresses of things is in the DHCP server section and in a subsection entitled "address reservation", so I think I am doing it right! Thanks for the responses.

Add Reply

Likes (0)
×
×
×
×