Naim app freezing after android updt

TJSTAR posted:

I have a perfect  network with no drop out on any app or any device.. My Galaxy S7 phone is actually great with every other app I throw at it.

My system is BT infinity 80.b.  Netgear router.  DLink switch. Audioquest cat7 Ethernet cable.   Galaxy S7 control.. Naim NDX. Latest firmware. Qnap NAS. (NEW)

However the Naim app is slow. Dreadfully slow to browse between folders. (I only use folder view)

I would pay  a lot of money just to understand what the issue is. If I use Bubble or indeed Qnap's own apps on my phone they are like lightening.  The naim app is just so slow. The artwork firms i  2 or 3 stages like dial up internet used to be.




The slowness in artwork rendering that you describe is definitely a network issue not the app and your 272 should stay connected all the time (like mine does for example).

You can take the advice or not, as you choose, but if it were me then I would be changing that router. They cost very little. I probably would change the switch at the same time too, as they cost very little too.



David I don't have a 272. My kit is as described above and my router cost an arm and a leg to upgrade on the BT infinity one.

I'm at a loss. As described my 80mb network runs like a dream with everything else. The app is not just slow rendering artwork  but also clunky when browsing between folders.

I even stripped out all the embedded artwork from all 14,000 tracks. Just to see if that helped. 

It's good your system works though. Maybe it's something in an accumulation of my kit. I've tried lateral thinking to no avail.


Very sorry. I was confusing the two problems running in this thread. It's what happens when one is watching the progress on the non-reshuffling of Mrs May's cabinet at the same time.

I don't use the Android app myself, but I don't remember having seen this reported before, even during beta testing.

Thinking laterally, as you have already done but because I don't have any other ideas currently,  I think I would be taking the phone to my Naim dealer or to a mate with a Naim streamer, and putting it on to their wifi to control their streamer and seeing whether the slowness travels with the phone, as it were. Another thought might be to try running a different Upnp server on your NAS and see whether or not that displays the same issue.

I will keep thinking....




Ive tied to set it ip with fixed ip addresses with my limited knowledge of this sort of thing but this didnt seem to make any difference to anything.

I may have tweaked a few other items but I'm not confident in this area so any advice would be greatly appreciated. The router is a Netgear D6400. I know how to get into the main controls and play from there. I also toyed with the idea of using QOS bit again disnt feel confident of maki g changes.


Yeah good shout david. I think the phone idea is a good one. Bit i dint kniw of anyone locally who has naim kit unfortunately.

Maybe I can think of another way of testing this though. My wife has an S6 and she gets the same issue.

Maybe worth testing an iPhone though on my network. Now to find some friends...

Oh and great suggestion about trying a different server. I'm now using asset 5.1 I was using twonky. Both the same also tried mini and plex.. 

I was wondering how long it would be before politics got in to the thread ha ha



Fixing IP addresses isn't necessary and wouldn't affect your slowness issue at all. That router should be ok. You could try resetting it to factory settings I suppose. I don't think it's necessary to make any special adjustments in the router on such a simple network for the relatively undemanding use we are talking about.



Yeah that's what I also thought.  It should be pretty straightforward an operation. 

Tried resetting it and upgrading to latest firmware. Sorry I should have mention as that earlier.

I'll keep searching. I'm sure it's going to be something very stupid...

A plant in the way or something lol...


I know the IOS app much better than the Android app and there isn't a problem with slow reaction on that at all, even on an old iPhone 5 I was playing with recently. So finding a friend with an iPhone or iPad would be a good idea. Also maybe there is a forum member who lives near you who would help. Finding one who lives near you might be tricky, but it has to be possible!



Without seeing the setup it's hard to do the diagnosis, but there are some general things.

First simplfy the network as much as possible (Router, unmanaged switch, NAS and streamer only), check for IP address clashes.
Try the network

Second turn off IGMP snooping (leave IGMP on).
Try again

If this works...

Third, use DHCP addressing for all devices (mixing DHCP and static IPs only works if you know how to configure the ranges).

Fourth, ensure you only have one DHCP server,
Try it again.

Fifth add back devices onto the network & try again with each new device added.

Thank you both ok I'll have a play over the next few days then and do a little industrial testing.  So nice you have taken the time on your Sunday wintry and help.

My postcode is CV37 (Stratford upon avon) for anyone reading this whò wants to help a naim buddy and perhaps do a little cross testing.