Naim App shut down streaming

Maybe someone can help me. Since the last naim app. udate, I have problems with the app up to the level that it stops playing my streams. 

I have a Sygnology ds 112j NAS and a ND5XS. Last week-end I tried several options to find out which component was the problem. Connected the NAS directly to the ND5 (outside network) and this played fine without any interuptions. Replaced NAS back into the network and operated the ND5XS by remote control with the same fine result. As soon as I opened the app  the buffer indication on the display of the ND5 run empty until the track stopped playing and never recovered. I see this happening in both HD files (96 Khz and DSD)  and CD 44,1 Khz files.

Anyone a suggestion to solve the issue? It is really something new, as I run this system already for some years now and never had any problem. No changes in the setup have been made.



Original Post

Have you tried a complete system shutdown & sequential power up ??    Start the wireless hub first & let it finish its start routine,  then the NAS & let it finish,  then ND5 & finally the app tablet/phone.  It may also need an app reset or delete & reinstall so that it activates the 'Find Rooms' feature.

Hi, I have exactly the same issue on both my mu-so's (connected via WLAN) and my NDX (connected directly by wire). I use a Synology DS211, a FritzBox 6490cable router, and an AirPort Time Capsule for WLAN. All working fine with my Naim components for some two years now - even happily playing multi-room together ;-)

Since the latest App Update the streamers randomly interrupt whenever I use the App, and if it was only open on my iPhone without touching it. As long as I do not "really" use the App - which means, select a track and immediately close the App afterwards, everything works fine (also on hi-res). The same if I select tracks via the front panel of my NDX. But only changing the volume through the App or selecting another track will trigger interrupts. After spending several nights and a few weekends on reconfiguring my network, rebooting, reconnecting, rewiring, and what have you..., I am at my wits' end. 

As I see the same effect with both my Mu-So's and my NDX, and as all three streamers run fine without the App, it cannot be a network, NAS or device issue. All components are on latest release and I do not have any other issues with my installation.

Any thoughts or help (perhaps also from Naim Customer Service) would be highly appreciated.

Thanks, Robert.

Little Update: I just reinstalled an older version of the App but still see the same strange behavior... Hence, there must be an issue in the communication between the streamer and the App, caused somewhere in the guts of my Network.

All components I use are said to be pretty reliable, and I have already reduced them to the minimum. Using the WLAN from the router didn't make a difference from using the AirPort WLAN or the cable connection. All runs well in any configuration, as long as I do not use the App - very strange...

I just wonder if this is due to the Synology not the app. There's a thread in the Streaming Forum about the latest Synology DSM update - see posts from Huge amd MikeB about it. I had a similar problem to the one you describe. I uninstalled Synology Media Server and reinstalled a previous version. Make sure you set Media Server not to install auto updates (until Huge and MikeB say it's ok, that is!) That seems to have solved the problem for me.

Peter, if you are playing a track and it stops mid way caused by the buffer emptying then that narrows things down.. it's unlikely to be anything to do with UPnP or the Naim app per se. Media when playing is just a simple source, destination transfer of data. So assuming the network does not become disconnected, ultra unlikely, and your wired network is not chronically loosing TCP data such as might happen with Powerline Adapters (not really a wired network), the most probable issue in my experience is some sort of TCP flow control incompatibility between source and destination, or an issue with the source media server implementation. The Naim streamer signals to the sender such as a NAS in specific ways depending on the rate of transfer. Therefore I would suspect first the NAS operating system or media server implentation on the NAS.. can you try an alternate media server such as on a PC or Mac and see if that works better?

To add to Simon's post - a few questions - When did this all start ??  Do you have your Synology set to auto update ??   What media server software are you using on your Synology DS112j ???  I ask because Synology have updated both the DSM (OS) & their native UPnP 'Media Server' software on 25/2/17,  unfortunately whilst the DSM is OK,  the new 'Media Server' does not work correctly with it on NAS units running single core CPU (your DS112j) & affected units need to have 'Media Server' manually changed to the previous revision.      Also your DS112j is a very basic 1-bay & its processing power is not great by today's standards,   maybe time to think about moving to something better.    

To better understand what is going on in relation to the above:  when your ND5 & NAS are playing,  look at the Synology webpage & read the CPU & RAM use,  & while you're in there what DSM & Media Server revision numbers are you on.  

Can you describe your system a bit more,  how is it wired ?  (NAS to ?? to ND5) etc ,  is it all ethernet, is any part ethernet over power, is anything wireless,    what make/model is the wireless hub/router.

Hi guys,

your hint on the media server software was spot-on

My DSM recently and automatically (which I turned off now) updated the Synology Media Server to Release 1.7.0-2810, which obviously caused all the mess. Looking in the Package Center, I found the newest release to be 1.6.2-2770, so obviously Synology recalled the latest version which they pushed out for automatic update end of February...

Anyhow, deinstalling 1.7.0-2810 and installing the now "newest" Release 1.6.2-2770 solved the problem for me. At least I learned a lot about my network, NAS and stereo configuration during the these nights and weekends - an finally got me a user in the Forum...  

Now I can spend my Sunday enjoying music instead of reconfiguring equipment... Thank you so much!!!  


No probs,  I hope its the same solution for Peter.    

Why don't you add your system details in your profile,  its often helpful to look at that for clues when diagnosing problems.  

............  you have good taste in avatar's.        

Yes I have the same better looking than me avatar,  I met my young lady in Sabi Sands (private sector of Kruger NP)      I go to SA a few times each year so get to see big furry stuff very regularly.   I was last in Serengeti (plus Kenya) in 2012.

Nice system  ............   

Hello to everybody who was so kind to react to my question. It is very nice to receive the ideas and suggestion to get you to the next step. Last week, I was out on a business trip to Asia so unable to reply, but here it is:

Based on your suggestions I installed the new media server software. Unfortunately this did not do the trick for me. Then I issued a ticket at Synology Support site. Today, I received below reaction:


Thank you for the inquiry.

This is a known issue which our developers are working on and will be fixed in the next Media Server package.
For now as a workaround, please kindly remove the current version of Media Server package and manually install the previous version of the Media Server package.

You can download previous versions of the Media Server package with the link below:

We apologize for the inconvenience.  

So I had to remove media server package, as a down grade to a earlier version was not allowed, and after reinstalling I installed the downloaded version.  And YES, it works again!  Flawless, the speed in my system is back and CPU usage is low again.

For now I will keep the automatic update in status "Off".

Thanks again to you all, and as said by Robert, : I can enjoy listing music again  !!