Naim Mu-so updates

So I have been unable to play Spotify on my Mu-so using wi fi. I believe that the recent update should have resolved this issue but when I go to "check for updates" on the Naim app the page just hangs. I am connecting via a Virgin Media Super Hub 3.0 but now also have BT Whole Home wi fi. Any ideas as to how I can complete the update please? Thanks

 

Original Post
mantona posted:

So I have been unable to play Spotify on my Mu-so using wi fi. I believe that the recent update should have resolved this issue but when I go to "check for updates" on the Naim app the page just hangs. I am connecting via a Virgin Media Super Hub 3.0 but now also have BT Whole Home wi fi. Any ideas as to how I can complete the update please? Thanks

 

Are you  using the iOS app, or the Android app, mantona? Are you connecting the Muso with an ethernet cable? If not, what colour is the LED on the Muso, next to the USB port? And are you able to stream music from an internal source (i.e. music stored on a home server) via Wifi? 

So I am using the iOS app and connecting wirelessly. The light is showing white. I have not tried the Ethernet connection (is it still controlled via the iOS app?) I don't know how to stream music from an internal source over wi fi (advice would be appreciated.)

 

If the Muso LED light is showing white, it means you're connected to your BT Whole Home Wifi. On which basis, don't worry about the ethernet for now.

I think as Hungry Halibut said, my next port of call would be to try iRadio. If you can play iRadio, there's no reason why you shouldn't be able to stream from Spotify - i.e. your Muso can "see" the internet.

I can't remember if the Muso comes preconfigured for iRadio - probably not? Just go to your app, and choose iRadio from the input section at the top of the screen. Not sure where you are, Mantona, but choose a station, and you should find it starts streaming to the Muso.

 

it's a strange thing. I've gone through the Mu-so set up process again this evening (probably for the several hundredth time) and the same thing happens every time. I get to the airplay set up and get the message "unexpected error occurred." Never mind I think - the white light is showing so I must be connected. Internet radio plays fine but Spotify remains problematic. When I click on Spotify in the Naim app it opens the Spotify app. When I choose and play a song in Spotify it plays only on my iPhone (never on the Mu-so.) I also have a QB and it has exactly the same problem.  I believe that the most recent Mu-so upgrade solves the known Spotify problem but when I check for upgrades for the Mu-so and QB in the Naim app the page just hangs. I am sure (or maybe hope) that if could complete the upgrade the problem would be solved. I have spent most of 4 months of ownership extremely frustrated and using the Mu-so and QB as separate Bluetooth speakers. This forum is really my last gasp hope.

Hi Mantona - you have my sympathies. I don't use Spotify (I'm with Tidal), so not familiar with the process of using Spotify - but out of curiosity I created a free Spotify account, and go so far as the attached (see link). Seems I can't link up my iPhone to the Muso unless I have a Spotify Premium account - can you confirm you do have a Spotify Premium account? 

https://1drv.ms/f/s!AkSCGXPTFCpBjtw-3MXN0Z_oWvRYRA

Duncan

Hi Robert yes I’ve seen that but neither of my devices are shown as available. I suspect this is because Spotify only show Airplay devices and my set up also breaks down at the Airplay stage.

yes Duncan I do have Spotify Premium. I did have Tidal but the connectivity problems meant that I was playing it over Bluetooth most of the time. This seemed like a waste of money so I cancelled the Tidal sub. (The Tidal problem was slightly different - I could connect but there was a lot of buffering which didn’t really enhance the listening experience.

I do still wonder if the Ethernet connection if the way forwards so I can complete the upgrade and then take it from there.  However I’m not sure what I do once I’ve connected the Ethernet cable. Should I go through the new product set up again and then control the Naim using my Naim iOS app? I

 

 

 

 

mantona posted:

Hi Robert yes I’ve seen that but neither of my devices are shown as available. I suspect this is because Spotify only show Airplay devices and my set up also breaks down at the Airplay stage.

yes Duncan I do have Spotify Premium. I did have Tidal but the connectivity problems meant that I was playing it over Bluetooth most of the time. This seemed like a waste of money so I cancelled the Tidal sub. (The Tidal problem was slightly different - I could connect but there was a lot of buffering which didn’t really enhance the listening experience.

I do still wonder if the Ethernet connection if the way forwards so I can complete the upgrade and then take it from there.  However I’m not sure what I do once I’ve connected the Ethernet cable. Should I go through the new product set up again and then control the Naim using my Naim iOS app?

 

 

 

Hi again mantona - I'm really not sure about the Airplay thing. So far as I understand it, Naim offers native support for Spotify and Tidal within the Naim App - i.e. you shouldn't need to Airplay either Spotify or Tidal to the Muso, but use the Naim app to manage the communication to your Musos over your home network, either via ethernet or Wifi. This allows Naim to provide multiroom support.

Again, so far as I'm aware, my Superuniti doesn't do Airplay, yet you'll notice that the link to the Superuniti was in the Spotify screen image (Super-OBBE) I sent previously. I also note that this screen lists separately "More Devices - Airplay & Bluetooth", which to me suggests that the connection to the Muso is via Wifi/ethernet - but only for Spotify premium accounts. 

I suspect that others with more direct Spotify experience may be better placed to advise?

Re using ethernet - yes, you would always get a more stable experience with ethernet compared to WiFi - though the BT Whole Home mesh wifi is very good. You mentioned that you had issues with Tidal over Wifi - was this before you introduced the BT mesh Wifi? What is the speed of your internet connection? Tidal is known for giving issues where the home network isn't optimal for carrying wide bandwidth music files (as opposed to the compressed files used by Spotify). 

You've supplied some of the pieces of the jigsaw, just not all I think to quite work out what's going on here...

I've never called Naim for Muso support - never needed to - but I think I'm right in saying they have a separate support line for the lifestyle products (including the Muso range) - have you called them at all?

Duncan

 

 

 

 

 

Yes Hungry I’ve seen “devices available” but when I click on it neither my Mu-so or QB are shown (despite them showing the white light meaning they are connected.)

yes Duncan you are right and I apologise for providing just some of the pieces of the jigsaw - probably a result of spending 4 months trying to get the devices to work as they should. There is an issue with the Virgin Media Super Hub 3.0 (identified when I called Naim support.) All wi fi is dual band and you can choose whether to connect at 2.4GHZ or 5.0GHZ. The Super Hub 3.0 doesn’t offer that option and will use the best available connection. Sounds good but the Mu-so doesn’t like the 5.0GHZ so at the suggestion of Naim Support I have restricted the Super Hub to the 2.4GHZ. 

I have only used Tidal on the VM Super Hub but it may be an idea to resubscribe and try it out on the BT Whole Home wi fi. 

mantona posted:

Yes Hungry I’ve seen “devices available” but when I click on it neither my Mu-so or QB are shown (despite them showing the white light meaning they are connected.)

yes Duncan you are right and I apologise for providing just some of the pieces of the jigsaw - probably a result of spending 4 months trying to get the devices to work as they should. There is an issue with the Virgin Media Super Hub 3.0 (identified when I called Naim support.) All wi fi is dual band and you can choose whether to connect at 2.4GHZ or 5.0GHZ. The Super Hub 3.0 doesn’t offer that option and will use the best available connection. Sounds good but the Mu-so doesn’t like the 5.0GHZ so at the suggestion of Naim Support I have restricted the Super Hub to the 2.4GHZ. 

I have only used Tidal on the VM Super Hub but it may be an idea to resubscribe and try it out on the BT Whole Home wi fi. 

Hi again mantona - thanks for the clarification, and absolutely no need to apologise! As many members of this forum will attest, it can be a struggle to get things working within the limitations of your home network. Many wifi routers offer dual band (2.4GHz/5GHz) wifi, and have done for some years, though a recent trend seems to be for routers that automatically assign a specific band to a device trying to connect to wifi. From what you say, it seems that to get around this, you've restricted the VMSH to 2.4Ghz only.

I'm slightly confused by this though, because since you've added the BT Whole Home Wifi, I would assume that you would turn off the Wifi offered by the VMSH? This makes sense because otherwise, you'll have two competing Wifi networks within your house, which will not only cause interference, but potentially mean that you've got some devices connected by Wifi to the VMSH and some to the BTWH Wifi. Can you confirm that your iOS device and your Muso are on the same Wifi network?

To complicate matters, the BTWH Wifi also features band-steering - i.e. it automatically assigns devices trying to connect to Wifi to either the 2.4GHz or 5GHZ bands, but Naim have confirmed this should be fine - see post from Phil (Naim support) in March 2017:

If everything in your network is working correctly then it doesn't matter whether devices are connected to your wired network or to either your 2.4GHz network or to your 5GHz network ... they will all be able to communicate and "see" each other.

What does often happen though is that bits of networking kit "misbehave" and either don't bridge protocols correctly between wireless and wired networks (BT HomeHub 3s and 5s seem to be a devil for doing this - we've seen them going from working fine to dropping packets massively in our own testing here) or go into low-power or sleep modes and don't wake up correctly (we've seen a number of different Ethernet Over Mains / Powerline Ethernet adapters that do this too).

I often get phonecalls from people saying that they have been told that they must have all their devices on a 2.4GHz network and that is completely incorrect and if that is the case then that's because there's an issue with the underlying network infrastructure - if it's all working as it should be then wired, WiFi 2.4GHz and WiFi 5GHz should be completely transparent to each other.

Since the Muso only supports 2.4GHz, I'd expect it to connect on that band, and your controlling iOS device should be able to see it whether it's connected on 2.4GHz or 5GHz. That's exactly how I'm using it at the moment, albeit with Apple Wifi kit, not the BTWH Wifi.

Hang on in there - it will be worth it!

 

 

Thanks Duncan. The BT Whole Home wi fi mesh connects to the VMSH by ethernet cable and the connected discs then effectively extend the wi fi signal by sending it onto the other discs placed around my home. It follows that the ISP remains Virgin Media.

Thanks for your words of encouragement!

 

mantona posted:

Thanks Duncan. The BT Whole Home wi fi mesh connects to the VMSH by ethernet cable and the connected discs then effectively extend the wi fi signal by sending it onto the other discs placed around my home. It follows that the ISP remains Virgin Media.

Thanks for your words of encouragement!

 

Hi Mantona - you're right in saying that the BT Whole Home wifi connects via ethernet - but you're mistaken in thinking that it extends the existing Virgin Wifi.  The Whole Home doesn’t extend your existing Wi-Fi signal but rather creates its own, simply relying on the router for its wired network connection. Therefore unless you turn off the Virgin Wifi, you'll end up with two Wifi networks in your home.

Of course the ISP remains the same - the BT Whole Home Wifi isn't a router, like the Virgin box - it simply dishes up the signal provided by the Virgin box, which continues with its duties providing the internet connection.

I suggest you check out which Wifi connection you're iOS device (?phone) is connected to, and also the Muso?

Indeed, Hungry Halibut is quite right in stating that you need to configure your Virgin box so that it is in modem mode - that way, all it does is talk to your ISP (Virgin), and the BT Whole Home Wifi handles the Wifi part.

I'd take a guess that your iOS device and your Muso are connected to different Wifi networks (the BT Whole Home Wifi and Virgin respectively), and that's likely to be the reason for the issues you're having...

Duncan Mann posted:

Indeed, Hungry Halibut is quite right in stating that you need to configure your Virgin box so that it is in modem mode - that way, all it does is talk to your ISP (Virgin), and the BT Whole Home Wifi handles the Wifi part.

I'd take a guess that your iOS device and your Muso are connected to different Wifi networks (the BT Whole Home Wifi and Virgin respectively), and that's likely to be the reason for the issues you're having...

Not sure about that. In modem mode, you need a router to dish out the IP addresses. From what you say, the BT thing isn’t a router. If that’s the case, putting the hub into modem mode won’t work. The key thing seems to be to turn its WiFi off. 

mantona posted:

Great - that's really helpful to know both. I'll give that a go and report back.

No worries. Just to confirm, from the Virgin Media Help pages:

Hub 3.0

Enabling modem mode allows you to connect your own WiFi kit to the Hub 3.0, effectively turning the Hub 3.0 into a stand alone DOCSIS3 cable modem.

To enable modem mode on your Hub 3.0

  1. Make sure you are connected (wired or wirelessly) to your Hub 3.0
  2. Open your Internet browser
  3. Log in to your Super Hub's settings page by entering 192.168.0.1 into the address bar of your Internet browser
  4. Enter your Hub 3.0 settings password. The default password is printed on the bottom of the Hub 3.0. If you have changed the default password, enter that password instead
  5. Once you've logged in, click Modem Mode on the left
  6. Click the option next to Enable Modem Mode and then click Apply changes

Note: Once in Modem Mode, the IP address you use to access your Super Hub changes from 192.168.0.1 to 192.168.100.1.

Don't forget to reboot everything after making the above changes - it's likely that you may need to connect one or more of your wireless devices to the BT Whole Home Wifi, as they may currently be connected to the Virgin Hub. 

You

Hungryhalibut posted:
Duncan Mann posted:

Indeed, Hungry Halibut is quite right in stating that you need to configure your Virgin box so that it is in modem mode - that way, all it does is talk to your ISP (Virgin), and the BT Whole Home Wifi handles the Wifi part.

I'd take a guess that your iOS device and your Muso are connected to different Wifi networks (the BT Whole Home Wifi and Virgin respectively), and that's likely to be the reason for the issues you're having...

Not sure about that. In modem mode, you need a router to dish out the IP addresses. From what you say, the BT thing isn’t a router. If that’s the case, putting the hub into modem mode won’t work. The key thing seems to be to turn its WiFi off. 

You could be right, HH - worth checking. I'm not familiar with the VM Hub. If that is so, then there must be a way of turning off the Wifi within the Hub. Google no doubt will have the answer...

Duncan Mann posted:

You

Hungryhalibut posted:
Duncan Mann posted:

Indeed, Hungry Halibut is quite right in stating that you need to configure your Virgin box so that it is in modem mode - that way, all it does is talk to your ISP (Virgin), and the BT Whole Home Wifi handles the Wifi part.

I'd take a guess that your iOS device and your Muso are connected to different Wifi networks (the BT Whole Home Wifi and Virgin respectively), and that's likely to be the reason for the issues you're having...

Not sure about that. In modem mode, you need a router to dish out the IP addresses. From what you say, the BT thing isn’t a router. If that’s the case, putting the hub into modem mode won’t work. The key thing seems to be to turn its WiFi off. 

You could be right, HH - worth checking. I'm not familiar with the VM Hub. If that is so, then there must be a way of turning off the Wifi within the Hub. Google no doubt will have the answer...

OK, taken from BT's Help pages:

 
Re: Whole Home Wifi Problems after getting a Superhub 3
The Superhub 3 in modem mode is just a modem, i.e. It does not perform as a router any more.

If you don't have another router (the BT Whole Home does not have router functions unlike some of the mesh WiFi products) you'll need t to put the Superhub back into router mode.

Do that and then just switch off the Superhub's own WiFi and I think you'll have what you need.
mantona posted:

But i’ve only had the BT Whole Home wi fi for a week and only got it because of the problems in connecting with the VMSH 3.0 (we live in an old house with solid walls.) 

Have you connected anything to it (the BT Whole Home Wifi) - i.e. your iOS device running the Naim app?

The ideal solution is wired connections. Both our Qbs are wired. The Virgin hub is pretty useless here, which is why we went the apple route. The Extreme does the router duties, with an express upstairs to extend the wireless network. The nice thing about the apple stuff is that it’s really, really simple. Maybe the BT is too.

Are you able to run wires for the mu-sos?

Yes I’ve connected a number of devices to the BT Whole Home wi fi including my iPhone. I haven’t been able to connect either of the Naim devices to it though.

A wired connection is very much last resort given our home with solid walls and solid floors. It’s either unsightly or will have me drilling through walls.

i’m going to try turning wi fi off on the VMSH leaving it as modem and router and see if that works. Any ideas on how to do that? If not I can google it..!

Here you go, Montana - from the Virgin Media Help Pages:

Follow the instructions below if you'd like to disable the Hub 3.0's broadcasting of the WiFi signal. If you change your mind, you can follow the same steps to re-enable broadcasting.

  1. Before you disable the Super Hub's WiFi signal, make sure that your computer is connected to the Hub 3.0 via the supplied Ethernet cable
  2. Access the settings page by entering the web address shown on the Hub 3.0 sticker. For a guide on how to do this, please see Configure Advanced Settings on your Virgin Media Hub
  3. Once you have logged in click Advanced settings then Wireless and then Wireless signal
  4. Click the options for Disable 2.4 GHz and Disable 5 GHz.
    Wireless Signal

Any devices on your WiFi network that were connected to the Hub 3.0 will now be disconnected. The Hub 3.0 will be unable to accept any WiFi connections until the above process is reversed (re-tick the enable options from Step 4).

With the WiFi signal turned off, the Hub 3.0 will be able to accept connections only from devices that are physically attached via an Ethernet cable to any of the four Ethernet ports on the rear of the Hub 3.0.

You're potentially going to have to connect other Wifi devices to the BT Whole Home Wifi, including the Naim Musos - I see no reason why they shouldn't connect though. 

There seems be a suggestion that you need to connect your BT Whole Home Wifi to ethernet Port 1. 

It's also worth stating that each Whole Home Wifi disc has an ethernet port. The Master disc is connected via ethernet to the Virgin Hub - but the others (not sure how many you have) will have a spare ethernet port which you could use to connect your Musos. Worth a try, once you've taken the Virgin Wifi down. This would have the advantage of being plug and play...

mantona posted:

Wow! Wow! Wow! That has worked - many many thanks Duncan ( and Hungry..)

Hey, that's great news! Between us we seem to have sorted you out, and hopefully you're getting both Musos singing with Spotify now! Have you tried the multiroom option yet? It's great for parties

I'm curious - did you finally get the Musos connected with Wifi or Ethernet?

Duncan

Well, I'd say that is a bit of a result all round. Glad in a way you have sussed out connecting the Musos by both Wifi and ethernet as you'll be an old hand at it when you've become addicted to Naim and get your next Muso (or hifi!).

BTW, your decision to buy the BT Whole Home Wifi was inspired - they're cracking bits of kit for the money, and very stable in my experience.

If you want some advice in the fullness of time on streaming from internal - i.e. music files stored on a PC or hard drive (NAS), there's a wealth a people here on the forum who will be happy to steer you towards good solutions. 

Happy listening!

Likes (0)
×
×
×
×