NStream stops responding

I have a Superuniti that connects to a Qnap NAS (Twonky) via Ethernet for the music library. I control the Superuniti ether by iPhone or more usually via ipad. I seem to suffer quite frequently from issues where nStream loses the connection I.e. at least once during every listening session - "Streamer not responding" with the option to "Try again" or "setup".  Usually after a period of time the connection will be re-established. I only have one instance of nStream running and the wireless network connection is on full strength.


Can anyone help me diagnose what the issue might be? I can't identify any pattern or system reason as to why the connection fails. I am using the latest versions of nStream and the latest software version on the Superuniti.

Original Post

Same issues in my house as well,  again no issues with signal strength.


I also find that the nstream client cannot connect to the upnp server on occaision.  Again after a while it comes back on line.  While the nstream client cannot connect to the server  the uniti can still play files in the queue.




I have the same issues as David. My setup now generally works fine but sometimes n stream stops responding. I usually just switch n stream to compatibility mode. You lose playlists but generally seems a bit more stable.


After a day or so everything is usually working again.

I have more or less the same issue, but then it seems as if nstream is still working, but the volume controls are not or there seems to be no connection and browsing through UPnP folders happen in the cache memory only and when want to play a new song or send a command it doesn't respond.


This can be solved very easily in my case by pressing the home button or whatever it is called on the ipad and then reopening nstream. It is sometimes ennoying, but since the symptoms can be solved easily, i don't really care anymore.


Maybe you have the same issue? Just try reopening nstream and see if it works.


btw: i have an ndx with sn and qnap twonky nas.