Problems Connecting repaired Naim UnitiServe SSD

The below is a listing of problems I am having getting a repaired UnitiServe SSD functioning.  I own Unitiserve SSD (US), Serial Number 311158.  It was sent in (not sure where) for repair by Crescendo Fine Audio, Arvada, Colorado, USA around the beginning of Dec 16.  The complaint at the time was it would not rip many CD’s.  I sent it with about 4 or 5 CD’s that it would not rip for examples of the problem.  I picked the US up 10 Jan 17 from Crescendo and Matt, the owner, said there were many things repaired, he was not very specific about what was repaired or replaced.  My system is OS X but I have Parallels if I need access to windows for any software.  

I connected the above referenced US to my system today.  Ethernet CAT5 cable from the US to an Apple Airport Extreme router used as a bridge to the main router in my lower level.  A bayonet cable to my Rega DAC and the power cable.  I started it up from cold, waited until the front panel logo quit flashing.  I then tried ripping one of the CD’s it would not rip before.  It started acting like it was ripping then spit the CD out.  I started up my n-Serve app on my iPhone,  The app said it could not find the Music Store in the ripping screen.  I have a 10TB Drobo on the network that has been and is still being used as the NAS music store.  This is the NAS that has a couple of TB of music already ripped from this US when it was working.  I continued to look at the n-Serve app to see what was going on.  The n-Serve app started out saying it was connected via using the n-Serve app on my iPhone and was starting to synchronize my music.  After this there was no listing of music as if it did not synchronize.  Eventually the n-Serve app stopped selecting the server.  Now there is no server showing in the Select Server window.  I tried finding it using the n-Serve for Mac and was unable to find the US.  Multiple attempts at doing this over about an hour has resulted in no progress.  Now I am ready to pull my hair out.  

Okay, somehow my repaired US has connected to the network.  I still can not get the server to see the Drobo-FS as the music store.  I have accessed the IP address to get to the Display Interface.  I am in the settings for the US in the Manage Network window. Access to the Drobo-FS is via an ID of MARKTURNER with a password.  The subdirectory on the Drobo is NAIM, is that what it is looking for?  Not sure where to go on this, as I have told you the seller of this device won’t return my phone calls.  I am sure it is something simple but I don’t go into the network to do any maintenance so the vernacular has me a little confused.  

I have now entered the Drobo-FS\NAIM address along with the Drobo IP address of with the ID and Password.  It scanned the network for approximately 10-20 minutes, the little orange light was solid and then stopped without the green light showing it was okay, there was no light, not even the red one.  I thought there was supposed to be a green light but I tried to look at my music library and it was not available.  I removed the share and restarted the process of manually adding a share. It started scanning the network again and what I did next must have screwed something up.  I went to the music store window and started the adding a music store process, it would not add a music store and the adding share process stopped with no listing of the share details in the window.  I then tried to add it again, manually, and it now says all the information entered is in conflict with a share already added but there is not information or listing of the share so I could maybe remove it and start over.  

My apologies if this is all confusing, I am confused on what to do next.  I can't add a share that conflicts with a share I can't  access in the Display Interface.  Maybe talking to someone on the phone and having them remote in or walk me through the process would help.  

In summary, I seem to have been able to connect to my UnitiServe SSD but can not get the share to connect to access my previously ripped music store and have done something to even have the Share show up in the Manage Share windows.   I have sent an email to the support contact without any reply as of yet.  Help is appreciated.

Mark Turner





Original Post

Hi Mark,

I sent my NS01 in for repair a few months ago, getting it to reconnect when I got it back was a nightmare.

The trick for me, having read a thread on the site, was to ensure the PC I was using & my NAS were in the WorkGroup NAIM; it then worked.

Hope this assists.


Thanks, M, but I am in a Mac OS X environment.  How do I translate to that.  Second issue, how do I get rid of the "ghost" HOST/SHARE file.  Can I do a factory reset to accomplish deleting this ghost and how do I do that?  I thought I saw a thread on how to do a factory reset but I can not seem to find it now

So this is a second-hand device that its first owner had on his own network??  If so, I'm sure that your problems relate to settings related to how it connected on HIS network are in there, and won't work for your network.  The advice to get Phil Harris to help you out is the best advice; it'll need those settings wiped out and then set up on your own network.  


IMO, the Airport Extreme used as a bridge will block the network discovery as all bridges do... (only N-Serve for Mac and DeskTop Client may see the server because they use special discovery tools (sockets), but not the app, the server and the streamers).

Can't you connect the US directly to a switch?

Do you really need a password for your Drobo? this creates more issues... you should have a ''Guest'' read and write access to the shared folders.

Workgroup is something from Windows XP, forget that.

When we repair servers, we do many resets of the unit, deleting all Shares and Music Stores you created. You must re-set them all.

So you should first solve the network discovery issue by moving your unit to a hard-wired switch, then, re-scan your network, re-activate the share you want to play from and promote to Music Store those in that state before you sent the unit.

Call us at Audioplus Services if you still have issues.

Crescendo should help you with that as well.

Manu, is there a number I can call to get this fixed? And a time/time zone to call?  I have been so frustrated before I did not even want to mess with it.  Anyway, I am ready to try again.  It is playing music and accessing the Drobo for already stored music but I still can not add new music as it can not find the store.

The local vendors for this product are not very helpful, including Crescendo.


Mark Turner



Bluemarkt posted:

Manu, is there a number I can call to get this fixed? And a time/time zone to call?  I have been so frustrated before I did not even want to mess with it.  Anyway, I am ready to try again.  It is playing music and accessing the Drobo for already stored music but I still can not add new music as it can not find the store.

The local vendors for this product are not very helpful, including Crescendo.


Mark Turner



the vast majority of local hifi vendors don't know how to configure these products: it is a shame!  how you can sell a product and don't know exactly how to install it?   when i bought my nds/ unitserve, i had to phone to naim in england for help and ask on the forum....

For your problem, i would connect the serve directly to a switch , switch the serve off, put the nas and serve in share on your mac, then switch the serve on.  But unfortunately i can tell you more.  I know, it can be a nightmare. Sometimes i regret my cdx2/xps2. Just put a cd and play.

HI Mark,

Call me at Audioplus Services, 800-663-9352, go to the receptionist and ask for me, we are Eastern Time (NY). I will be at the office for the next 3 days.

Have you done my recommendations about the bridge? I can only help if the Server is hardwired directly to a switch or the router, not through a bridge.

I can log to your network, Drobo is not officially supported (only because we cannot know all NAS drives on the market), but I can check what I can do.  You now that many dealers are unfortunately unhelpful with stock bought used...


Okay, my problem is fixed.  Here is how I fixed by problems connecting detailed above.  I started up n-Serve for Mac, went into my server name>Maintenance and looked at Network Stores since this seemed to be my problem, creating a network music store that is.  I deleted the Network Store \\Drobo-FS\NAIM as listed in n-Serve.  I moved the UnitiServe SSD to where it was sitting next to my network switch in my lower level next to the router.  I then reconnected the UnitiServe SSD to the switch directly and connected a keyboard, mouse and monitor to the UnitiServe.  The UnitiServe SSD was started up and I went through the adding of a share, this took a while to scan the Drobo.  I then added the music store manually via the Add Music Store button.  Again, this took a while to scan about 406 albums.  I tested it out by starting some music and adding discs that were not on the Drobo.  I powered all down, moved the UnitiServe back to where it connects to the music system and the Airport Extreme I use as a bridge to the network.  All seems to be running fine and playing music as designed.  To summarize, I apparently just needed to erase or delete an improperly setup share or music store and start over.  The moral of the story is be patient and wait for the green lights to come on, it took two times for that to happen on the music store but all is well now.

BTW, Manu and anyone else, this was not used stock, it was bought new from Blue Note in Denver, Colorado.  Hopefully they read this and improve their customer service.  Until they do I can not recommend them but will instead advise anyone asking to stay away from them.