Safari won't open – no issues with cookies etc, apparently. Why?

Hi to all,

does anyone have any idea why, after the last update of HighSierra on my MacBook Pro, I can't reach the page from Safari? The blue line does an inch or so then stops. The same if I try to go to

I have had to install Opera to be able to come here, and even with it, I have to pass through the main page, Connection and come to the forum. Any idea?



Original Post

Max, you're still having this difficulty with Safari? I'm no Mac expert - far from it in fact - but I'm guessing you have some plug-in that's perhaps causing a problem.

I too am using High Sierra (fully up to date) on a MacBook and all is so far fine.  Of course, I have probably now jinxed things for myself and will no longer be able to access the forum...

(in which case, thankfully I have a PC laptop, iPad, iPhone etc.. for just such a mishap)

Max did you try the suggestions I made in my earlier post?

What happens if you favourite the Forum in Opera? Can you now go directly to the forum from your favourite? Or does that not work either?

Also did you try restarting your router? Can you access the forum normally from other devices on your network e.g. Phone or tablet on your wifi?




yes, thanks, I tried your suggestions and I apology for not having reported yet. To answer everything:

- If I digit in Opera, it doesn't open it.

- If I change it into and follow the Connection route, it gets to the forum easily and quickly.

- I have just put this page into the bookmarks, then opened it in another panel from the bookmarks, and it opened immediately.

- I restarted and reset my router. It goes perfectly, but the issue with Safari remains.

- No problem entering the forum directly on my iPhone 6.

- Ghosts?




No way. I may have quoted the address wrong in my post up above, but I have copied and pasted Eloise's link directly in Safari and the blue line stops at 2 cm. Nothing goes further. Here on Opera the link is obviously working, and the direct address of the forum – if written properly – too.

Nothing of importance, of course, but it's strange. And I keep VPN on on Opera, so I am virtually logging in from who knows where in the world..

Tried again: all addresses work on Opera, none on Safari. But as I say, it seems a minor issue, so don't waste your time for me, please. Thanks for the help, David, Richard and Eloise.


Hi Max - sorry to hear this. Just to confirm that I am currently using a MacBook with High Sierra and have had no problems at all with the forums on Safari. Perhaps it's a cache problem? Have you tried quitting and reloading Safari; rebooting the computer? I have very occasionally had a similar issue with Safari and a reboot has solved it. 


I think it might have to do with having started to use Opera, a Swedish excellent browser which features ads block and VPN, a virtual IP address creator, that helps not being traced by websites, and that somehow the Gods of Apple who, like the Gods of ancient Greece, don't give a s*it about men but love to have control on their lives and mess up with them, do not like this.

I believe that if I erased Opera and re-installed the complete OS, everything would gel back again, but who cares? Isn't it a gas to be a pebble in the Mechanism once in a while?


Nothing of great importance, but: got the Mac rid of Opera, using AppCleaner, a small free app that finds all the files related to an application and erases them wherever they are; rebooted the Mac resetting the PRAM; opened Safari, went to and at last it opened the website normally.

Now it's all very fast and both website and forum open even more quickly than before. Mysteries.

Thanks to all for the suggestions. There was probably something with VPN my Mac (or my Internet provider) wasn't keen on.


Likes (0)