TIDAL "Can't Play" any tracks from the Naim App

Hello Titans.

Over the last few days I've been unable to play TIDAL via the Naim app on my SU. 

To attempt a fix, I've updated my payment information, reset the password, rebooted the router, my Apple Time Capsule, the SU and my iPhone all to no avail. When i select a track via TIDAL from the Naim APP, the SU says 'CAN'T PLAY".

Tidal plays fine from the TIDAL app on my phone and the desktop Tidal app on my MacBook. I've logged in and out of TIDAL on the Naim app but to no avail. The input is initialised and it has picked up my account details after entering the password.

Any ideas? 

A warm punnet of freshly-glistening thanks to the wizard that provides a solution.

Original Post

I've a premium account so I'm trying to stream to the SU in lossless. This has worked flawlessly for years.

There may have been a billing mess up when my old debit card was stolen last month. I've raised an issue with Tidal to investigate. The MacBook app, although listing a 'Premium Account' does not now offer Lossless streaming so I think it's an issue with card switch-over and payments. Thanks, Finkfan.

It appears my premium account has received May's payment and I'm good till mid June. So it's not the nicked debit card.

No streamed Tidal as yet though. @Tallan, I've rebooted everything from router to Time Capsule, to SU, to MacBook to iPhone and deleted and re-installed the app, two or three times.

I'll report more a bit later when there's a been a change. Thanks again to all.


ChrisSU posted:
Tallan posted:

Had the same problem; rebooting my Core server fixed it.

I find it hard to believe that a server has anything to do with a Tidal fault! (Assuming you are talking about a Naim Core, as opposed to a Roon Core?)

Roon Core.  Here it’s a Lenovo compact i5 Windows 10 desktop basically dedicated to running Roon Core.  This is the second time a reboot has been needed to get Tidal streaming working again on my various endpoints; I don’t know why it works, but it has.

Likes (0)