Weird Tidal problem.

All of a sudden, when opening Tidal throughthe NAIM app., my playlists won’t automatically play the next track when the previous one has finished. It either takes a long long time to do it, or it jumps to a completely different track (randomiser is set to the off position) or if I tap the next song, it displays the info., does nothing, then the info screen goes blank?

What the actual ....? Anybody else getting this?

Original Post

I have had the problem when starting an album it stops after the first track a few times over the past 18 months and it was resolved by restarting my system and all worked fine after that. Not sure of the cause or why restarting fixes. Hope you find a resolution........

So this morning, everything worked fine.

Coming back to it this afternoon, nothing worked. Dead as the proverbial Dodo.

I am using it via the NAIM app to play into my Hifi. After I went to my saved internet radio stations (on the NAIM app) and played from a couple of them, I tried my Tidal albums and instantly, everything worked again.
 
Is there some new problem between the two apps.?

Hi Mike,

I have noticed that logging out and back in to Tidal (via the Settings -> Inputs -> Tidal menu on Naim app) often resolves this “one track only” behaviour. I think it is similar to the need to re-log in on your phone Tidal app, but here we don’t get the notice to supply credentials. Maybe give it a whirl, see if it sorts you out. (Aside: the restart solution mentioned by others probably includes such a re-login to Tidal, so the advice is maybe compatible?). Best of luck

Regards alan

That seems to enable the following track to play when the previous has finished, but trying to jump to a different track will display the new information and the ‘pause’ symbol but the track itself will not play.

 I’ve got to the point of going over to Spotify, so just to start a Spotify 320 /Tidal FLAC comparison, I loaded the Spotify app on to myiPad and also enabled it in the NAIM app.

When I tap the NAIM Spotify logo, I get my Tidal content. If I disable the Tidal function and then tap the Spotify symbol, nothing happens.

Is this because I’m trying to use the free Spotify version?

I’ve just noticed that now when I open the NAIM app., I no longer get the Preset radio list immediately changing to the ‘Preset’ heading plus all the Tidal subsection headings with a column of all my Tidal albums.

Now, it just stays with the ‘Preset’ heading and list of stations. 

I would have put this under a separate heading, but it does seem that something peculiar is going on with the NAIM app/Tidal interface.

The question, in the absence of any announcements, is: what?

So, I tried using the Tidal app direct. Surprise surprise. It worked perfectly.

I then deleted and reloaded the NAIM app. When I opened it, I found the second display described above (‘Preset’ plus all the Tidal subheadings and a list of my Tidal account albums) had returned!

Tried using it with the same result. Would not play if I requested another track from the same album whilst playing one already. Displayed the info for the second track only, and then blanked out to ‘No Track Playing’.

What the hell is happening with the NAIM app?

Time to talk to NAIM support, methinks.

Mike -

Your situation seems to be quite frustrating and has been going for some time now... argh.

On occasion I’ve also seen the “slow to populate” initial behaviour on the app screen, where all four main headings (Albums, Tracks, Radio, Playlists) are not present for some noticeable period of time. I don’t recall the last incident exactly, but it usually lasts a few seconds or gets resolved in the background while I select something to play.

That said, I have noticed that it is sometimes Albums but sometimes Radio which is missing. The protocol seems to be that the app asks the unit for a list of items, then displays it on the screen; delays in populating the list are likely caused by the app (iPad) to firmware (Uniti in my case) communication socket. For the Tidal favourite Albums, I guess they could be requested by the firmware in response to the app request... I don’t think they are necessarily stored locally, since new favourites selected elsewhere (eg in native Tidal app or via Roon) show up immediately next time you are in the Naim app (and vice versa of course).

Ages ago, I had bad comms and connectivity on a Qute: eithernet, wifi, didn’t matter. Obviously a totally different situation to yours, but a complete reinstall of the firmware and factory reset helped. Sure, you’ll lose your programmed favourite iRadio stations, any locally created playlists, and the custom names and settings for your inputs... but it might be worthwhile to give it a try as that is the best way to clear all internal caches and restore the unit to a completely known state. If your local collection (on your NAS or other upnp server) is large, you could try clearing the cache to flush memory.

Also, and I’m totally guessing here, is there any chance you’ve seen a slow down in app-to-unit connection? Do your rooms repopulate quickly if you pull down from the top of your screen to force the “find rooms now” function? Switching between wifi and Ethernet might show differences, just for test purposes? 

In my experience, although other network functions can execute flawlessly, the Naim gear can be more prone to errors and odd behaviour that turn out to be connection related... even when that doesn’t really seem to make sense (and everything “just works” on other devices or native apps). 

Not too helpful and no guarantees I know, but maybe a lift knowing other folks are wishing you well as you work through this one!

Regards alan 

Well, my other thread got pulled so I’ll just continue moaning on this one.

Day four. The nightmare continues. Did a fill factory reset yesterday and it was OK for a while but soon collapsed back into the nonsense ballsup of freezing and uselessness again.

Dreadfully dreadfully dispiriting. And apparently my request for help from ‘Support’ will be attended to ‘within seven days’...

Hmm... sad and difficult news Mike.

If you have a computer you can leave on in your network, Roon is a nice thing to try: seems a complete bypass for the comms with the device as well as the control app. I forget which streamer you have, so I guess it’s unlikely you’re running a native endpoint (new platform only, not 272) but you could try it using optical out from your (Roon core running) Mac mini or whatever, or add an inexpensive non-Naim streamer such as the Allo DigiOne which is both a Roon endpoint and a regular UPnP streamer with all the usual suspects for interface and control (since you are considering such a path anyway).

I wonder if, as well as the factory reset, you have tried a fresh install of the firmware itself? Or, if you are really frustrated, if you would consider making a request to join the Naim beta test team ... the discussion on deeper technical issues is more detailed in that private forum. If you move to the latest beta firmware and have a non-standard problem, the software developers are really interested to understand your corner case, and it’s a very useful two-way interaction.

Regards alan

From Mike’s profile it’s an ND5 XS.  

Bearing in mind that the forum isn’t alive with people having problems like this with the legacy streamers, my bet is that this is a network problem and not a streamer or app issue at all. I know that isn’t very helpful but I bet that is also what Naim support say when they get round to replying.

best

David

Agree, David... not a common fault, not sure how it can be the app vs the ND5xs (I didn’t spot that, sorry). I’m a fan of using latest firmware and when beta program was first launched, the problems I was experiencing with Qute all went away (well, apart from poor wifi connection, which I solved by using an Apple Airport Express to do the networking). Obviously can’t promise developer attention as I’m just a customer / Uniti owner...

Also agree simplifying network and understanding what else works and what else doesn’t is a good start. The slow population of the Albums, Tracks, Playlists, Radio listing is a very strong clue even though it is not the biggest obstacle to using the streaming service. This should definitely be explored to understand quality of networking.

On Tidal, just to be sure: no other devices trying to stream at same time, right? If iPhones or iPads are logged in, that’s okay; if playing locally stored downloaded content in offline mode (allowed on up to three devices per single account), that’s okay; if trying multiple live streams simultaneously, that’s an issue and we have no transparent error messaging on Naim, so silent failure mode might be expected. Could try logging out of all Tidal instances then logging back in only on ND5 to check this idea.

If the ND5 is wireless, always best to check if a long wire temporary Ethernet connection (just draped across the floor or up the stairs or whatever) provides a fix or at least a different experience. Can also try other wifi receiver that connects to streamer via wire, but not needed if a long wire can be tried first.

All other usual debugging steps assumed: complete restart of modem/router, switches, devices, etc. Plus double checking all other network functions (web login to device status page; iRadio performance; local UPnP streaming performance) to be really sure it’s just the Tidal interface breaking down...

Regards alan

I mean none of the things I’ve done to try and fix the problem have worked.

I’m hard-wired, BTW.

There’s nothing wrong with Tidal, it works perfectly well through it’s own app both on my iPad and Samsung mobile.

My iRadio list works fine also. There’s something wrong when I try to interface with Tidal through the NAIM app to stream my albums and playlists.

Grrrrrrrrrrrr.

Obviously frustrating, and definitely you want Naim support to start chiming in when the work-week resumes. For sure call and email to get in touch directly.

I'm puzzled mainly at the sporadic networking connectivity that you are experiencing via your ND5. I know it's difficult to accept, but "Tidal is working fine" (or "my internet is working fine") is not incompatible with "my ND5 network connection is wonky and I'm having issues"... since I think the network connection to your ND5 is really what's problematic. That your "Albums / Tracks / Radio / Playlists" info on the app fills in wrongly / slowly sometimes is one sign; that you can no longer browse Internet Radio -> Location -> Europe -> United Kingdom -> All Stations is another sign... my app takes about  a tenth of a second to populate a list of goodness knows how many stations, starting with A.Radio 70s Juice and ending with 98.8 Castle FM. This new issue is clearly not a Tidal functionality problem. If your ND5 remote handset allows you to select internet radio and search through the list using the on-screen interface (the older Uniti boxes, including Qute, used to have this feature), can you see anything there (ie is it just on the iPhone app where it is missing, or is it not seeing it in the streamer). 

I have no idea what has changed for you: any sign of new firmware flashed to your ISP modem/router? any new things you've done in your house (switches, devices, whatever)? any chance the wiring has been touched, moved, dislodged? any joy if you remove the wire and go wifi from your NDX to your modem/router/access point?

alan

David Hendon posted:
Mike-B posted:

.........  why was the other thread pulled ???

I assume  it’s just that because Mike started a second more specific thread, Richard closed the earlier one.

OK,  I guess I missed that one as I was out most of yesterday.   Shame because I felt the thread was making progress.   Let’s hope, if it was as you suspect, that Richard can zap just the offending stuff. 

Certainly worth doing the update. If it’s the first streamer firmware update you’ve done, be careful to follow the instructions to the letter. A few people seem to have been running into problems with the required USB driver on their computer for this. 

Add Reply

Likes (0)
×
×
×
×